Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Strange battery issue

Discussion in 'Phantom 2 Vision Help' started by bernek, May 10, 2016.

  1. bernek

    Joined:
    Apr 8, 2016
    Messages:
    271
    Likes Received:
    43
    Location:
    Romania
    Hello guys,

    I was flying happily my 2 x 5200 mAh original batteries. The oldest one of them (having around 24 cycles) it was charged today from 45% capacity (was at storage voltage for 1-2 weeks) to full capacity 100%. When I plugged it in the charger the first time (the battery was turned off) the green lights didn't start flickering after removing it and plugged it again - this time turned on it began charging. After 30-45 minutes it auto turned off and the led on charger went green. I disconnected it and pressed once on the button to check charge and it was showing 100% all leds green.

    I went flying with this battery after maybe 2 hours and when I did put in in the phantom it showed only 1 led and a charge of 32%. I decided to fly since I knew I charged it fully 2 hours ago. The flight time was around 20 minutes and only after 15 minutes it began drop from 32%. It initiated autoland normally at 15% and the warning was at 20%.

    The battery reported the % of charge wrong but it worked perfectly. I wasn't flying high since I didn't want a crash if something went wrong.

    I never did the 8% discharge on batteries but did it today for both my batteries since I believe the reporting % remaining was wrong.

    Anyone had this strange behaviour ?

    I usually fly to 30% then land and when I want to put the batteries in storage I land at 50% and store them like that. Is there something wrong with my technique ?

    Thanks in advance.
     
  2. Mark The Droner

    Joined:
    Aug 26, 2015
    Messages:
    4,041
    Likes Received:
    1,181
    Location:
    Brookeville, MD, USA
    Other than not doing the deep discharge after 20 cycles, you seem to be treating the batteries correctly, IMO.
     
  3. bernek

    Joined:
    Apr 8, 2016
    Messages:
    271
    Likes Received:
    43
    Location:
    Romania
    Is everyone doing the deep discharge? I didn't do it because LiPo doesn't like low voltages ...


    Sent from my iPhone using PhantomPilots mobile app
     
  4. Mark The Droner

    Joined:
    Aug 26, 2015
    Messages:
    4,041
    Likes Received:
    1,181
    Location:
    Brookeville, MD, USA
    No - some don't do it. I do it.
     
  5. bernek

    Joined:
    Apr 8, 2016
    Messages:
    271
    Likes Received:
    43
    Location:
    Romania
    I think I will do this 8% discharge at 20-30 flights. I don't want to do it too often to stress the batteries but it seems that "older" ones (it has the 1.6.0.0 firmware this one) have problems with reporting the percentage left. Voltage was correct or something went wrong in the battery since it showed on the leds the same amount (low 32% even if it was 100% and it flew 19-20 minutes no problems).
     
  6. Mark The Droner

    Joined:
    Aug 26, 2015
    Messages:
    4,041
    Likes Received:
    1,181
    Location:
    Brookeville, MD, USA
    It could possibly be an out of balance cell.
     
    bernek likes this.
  7. bernek

    Joined:
    Apr 8, 2016
    Messages:
    271
    Likes Received:
    43
    Location:
    Romania
    That was the reason for the 8% discharge that I did. But still the voltage difference should be crazy high to show 32% instead of 100% ... I don't know how % is calculated from cell individual voltages or as a whole. I guess its combined voltage ... not sure.
     
  8. Mark The Droner

    Joined:
    Aug 26, 2015
    Messages:
    4,041
    Likes Received:
    1,181
    Location:
    Brookeville, MD, USA
    I'm not exactly sure either how that calculation works, but I know a low voltage cell will cause the battery to shut down, regardless of how much voltage the battery has as a whole. So presumably that fact is worked into the percentage calculation...
     
  9. bernek

    Joined:
    Apr 8, 2016
    Messages:
    271
    Likes Received:
    43
    Location:
    Romania
    I just flown today with both of my batteries and everything was perfect voltage/time/percentage. :) I guess the 8% helped !

    Recharged them to 2 leds (50%) and put them back into storage since the weather will turn bad ...

    The wait for my RE700 and ITELITE DBS-01 is not helping at all :p
     
    Mark The Droner likes this.