Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Standard camera goes limp after start up and gets extremely hot

Discussion in 'Standard/4k Discussion' started by Brandon Brown, Oct 13, 2015.

  1. Brandon Brown

    Joined:
    Oct 13, 2015
    Messages:
    1
    Likes Received:
    0
    I have had my Standard since Friday. I opened it Monday I have flown it 5 or less times. I have had no issues. I have had great flights and great camera shots. I went to fly it and the top says no signal. I can still fly the aircraft with no issue but the camera doesn't work. It shows a black screen and it is limp. You can't do anything with the camera or video mode. Also the Camera is super hot as in 5 sec or less you HAVE to take your finger off. Thoughts?

    I've tried deleting the app and redownloading it, switching the modes at the top of the remote, witching the Gimble from remote to pvl I think it is. I also tried using another phone. I was told to try an I pad but you cannot download Go to an iPad.
     
  2. RoyVa

    Joined:
    Apr 10, 2015
    Messages:
    2,248
    Likes Received:
    454
    Location:
    Virginia
    I would check the connections and make sure they are tight and making good contact. If you haven't changed anything that's the route I would take.
     
Loading...
Similar Threads - Standard camera goes Forum Date
Phantom 3 Standard vs Pro Camera Test Pro/Adv Discussion May 13, 2017
Phantom 3 Standard Camera Upgrade Standard/4k Discussion May 11, 2017
Standard Phantom 3 Standard - Telemetry without camera Phantom 3 Help Apr 30, 2017
Trade NIB standard camera for used pro/adv quad only Pro/Adv Discussion Apr 30, 2017
phantom 3 standard camera/motor issue Standard/4k Discussion Apr 29, 2017