Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Some help please.

Discussion in 'Phantom 4 Discussion' started by JamesA, May 2, 2016.

  1. JamesA

    Joined:
    May 2, 2016
    Messages:
    3
    Likes Received:
    0
    Just got a P4.
    My i-Pad is three years old, version 9.3.1 so I guess this won't work with P4.
    Can I upgrade my i-Pad to get these two devices working together?

    Thanks for the help.
     
  2. so you are wondering that if you get a new iPad, will the phantom 4 work with it?
    yes, the new-generation iPads work with the phantom series
    If you are asking if you can use both iPads at the same time, then no, you cant
     
  3. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    24,838
    Likes Received:
    7,546
    Location:
    Harrisburg, PA (US)
    JamesA, you'll need an iPad Air, iPad Mini 2, or something newer. You can find a list of recommended and commonly used devices here.
     
Loading...
Similar Threads - help please Forum Date
P3 pro Crashed now driving me Crazier than I was already ! HELP ,please!!! Pro/Adv Discussion Yesterday at 6:00 PM
Traveling with drones - Please SHARE your experience to help others Rules and Regulations Sunday at 1:38 PM
Professional Replaced broken ribbon cable & now the gimbal doesn't work at all! PLEASE HELP!!!! Phantom 3 Help Friday at 8:52 PM
Standard Help me please "Roll Problem" Phantom 3 Help Friday at 7:35 AM
Please Help - P4P Rocking During Hover Phantom 4 Pro Help Jun 20, 2017