Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

[SOLVED] P2V+ Motherboard LED?

Discussion in 'Phantom 2 Vision + Discussion' started by MickeM, Nov 22, 2014.

  1. MickeM

    Joined:
    Nov 22, 2014
    Messages:
    69
    Likes Received:
    0
    Hi there!

    (First post in this forum, welcome, thank you!)

    There is a LED on the motherboard inside of the DJI Phantom 2 Vision+ that doesnt light up att all.
    Should it? Colors? Meanings?

    Some hints:
    - The P2V+ dont work after a crash.
    - Wifi between extender and Phantom doesnt work (Phantom Connection Lost).
    - RC-receiver binds with the radio, but cant do anything with the radio, not even ARM.
    - Wifi between Android-phone and extender works fine.
    - Front right ESC-LED lights RED = Error.
    - Camera LED is GREEN.
    - Camera takes photos and films (when pressing the button on the gimbal, pictures stores on micro-SD).
    - GImbal is stabilizing on its own, works ok.
    - ESC-LEDs works.
    - Motors beeps as they would = probably works.
    - Wifi-module is changed, no difference.
    - Have tried to rebind with bind-button on Extender, no difference.
    - The RC-receiver and "Naza" got power (5.5V).
     
  2. ElGuano

    Joined:
    Sep 4, 2013
    Messages:
    2,219
    Likes Received:
    4
    Re: P2V+ Motherboard LED?

    Do you have a picture of it? Is it on the receiver and not the actual mainboard?
     
  3. MickeM

    Joined:
    Nov 22, 2014
    Messages:
    69
    Likes Received:
    0
  4. ElGuano

    Joined:
    Sep 4, 2013
    Messages:
    2,219
    Likes Received:
    4
    Re: P2V+ Motherboard LED?

    Hmm, no idea. I'll take a look next time I have my shell off.
     
  5. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    Re: P2V+ Motherboard LED?

    I don't think there is an LED on the main board.
    WHERE DO YOU THINK IT IS ?
     

    Attached Files:

  6. CityZen

    Joined:
    Oct 22, 2014
    Messages:
    940
    Likes Received:
    36
    Location:
    NYC
    Re: P2V+ Motherboard LED?

    There is an LED on the mainboard just to the right of the big IC. I haven't noticed it operating myself, though. (But I haven't much powered up the Phantom with the shell open, either.)

    As far as your actual problem, you should hook the Phantom up to a computer and run the Phantom Assistant to see if it can give you any clues.
     
  7. RichWest

    Joined:
    Nov 1, 2014
    Messages:
    405
    Likes Received:
    43
    Location:
    Houston, Texas
    Re: P2V+ Motherboard LED?

    I believe it lights up when you press the reset button....giving you an indication to rebind to the controller....
     
  8. MickeM

    Joined:
    Nov 22, 2014
    Messages:
    69
    Likes Received:
    0
    Re: P2V+ Motherboard LED?

    RichWest:
    Reset-button? Where? Do you mean the bind-button under the receiver under the mainboard that (little hole under the Phantom):
    - blinks red when there is no connection to the radio
    - blinks orange in bind-mode
    - off when connected to radio
    I still mean another LED, surface mounted double-LED on the mainboard (upper side, under the upper shell).

    CityZen: Exactly that one! =)

    RobinB: It looks like a LED to me and it flashes once in orange very weakly at startup.


    Anyway, I should do this...
    - Take a photo or mark on a photo where the LED is
    - Open up the other P2V+ I got yesterday and take a look (if it lights up, I still dont know what that means though)
    - Connect the Phantom to a computer as CityZen says. =)

    Big thanks, so far!
     
  9. MickeM

    Joined:
    Nov 22, 2014
    Messages:
    69
    Likes Received:
    0
    Re: P2V+ Motherboard LED?

    Nope... the LED is the same on the other P2V+ I just opened (which have the same camera-problem).

    At this point, I have two DJI Phantom 2 Vision+ that dont work properly.

    FIRST ONE (the one above):
    - Have connected to Assistant through USB and upgraded all (not the bin in the camera using microSD).
    - Motors didnt work, after calibrating RC one of them works. Three ESCs beeps very low and motors wont work.
    - Have calibrated GPS and compass
    - Cant View the switches in the Assistant (works on the other one), they arent there at all
    - Still gets the problem in my Samsung Galaxy Note II Android 4-app: "Phantom Connection Lost" although it binds perfectly with the Extender.

    SECOND ONE:
    - This one flies good
    - Same problem ans the FIRST ONE: Gets the problem in my Samsung Galaxy Note II Android 4-app: "Phantom Connection Lost" although it binds perfectly with the Extender.

    Many problems... =) Dont know where to start.
     
  10. MickeM

    Joined:
    Nov 22, 2014
    Messages:
    69
    Likes Received:
    0
    Re: P2V+ Motherboard LED?

    SOLVED!

    FIRST ONE:
    One ESC dead, Two ESC not working well (motor beeps very low). All motors and motherboard outputs to motors works. Changing them soon.
    The problem with the app, I didnt bind the right MAC-address. ;-)

    SEDOND ONE:
    Same app-problem as the above. Wrong MAC-adress.
    Why? Because the fields text are stupid. Camera bound = Enter Extender MAC-address. And New Camera = Enter Wifi-module MAC-adress.
    This one flies and works fine. ;-)