Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

SOLVED! Ever seen a gimbal doing this?

Discussion in 'Phantom 1 Discussion' started by Tito, Feb 19, 2015.

  1. Tito

    Joined:
    Jan 19, 2015
    Messages:
    32
    Likes Received:
    1
    Location:
    The Netherlands
    Hello guys.

    I was busy with my drone and for a long time the gimbal was hanging a bit to one side. It is a Chinese gimbal and I saw someone on here using the reset button to straighten it. But I think I did end the procedure to soon (unplug the battery). Now when I turn it on it does this:

    https://m.youtube.com/watch?feature=you ... SKTysNqq2s

    Did I wreck it? Is where a way to calibrate it correctly? It has a mini/micro usb connection. Can I re-install some software on it? Or do I need a new board?

    Btw if I unplug the compass it does get less violent.
     
  2. crash1sttime

    Joined:
    Oct 31, 2014
    Messages:
    923
    Likes Received:
    74
    Location:
    Manchester UK
    Re: Ever seen a gimbal doing this?

    Last time i saw this on a youtube video, it was because the wires were plugged in wrong, the pitch and roll cables were either reversed or on the wrong sockets, the gimbal tries to level the camera but sends the motors in the wrong direction.
     
  3. CityZen

    Joined:
    Oct 22, 2014
    Messages:
    940
    Likes Received:
    36
    Location:
    NYC
    Re: Ever seen a gimbal doing this?

    You should probably run the GUI software for the gimbal and verify the settings.
    (Search for "gimbal gui software". It's probably either simplebgc or basecam.)
     
  4. Tito

    Joined:
    Jan 19, 2015
    Messages:
    32
    Likes Received:
    1
    Location:
    The Netherlands
    Re: Ever seen a gimbal doing this?

    Oeh nice. Need to find all that out. I'll need the custom null firmware or something like that. I'll try to re-flash the thing this evening.
     
  5. Tito

    Joined:
    Jan 19, 2015
    Messages:
    32
    Likes Received:
    1
    Location:
    The Netherlands
    Re: Ever seen a gimbal doing this?

    Ok. I got it somewhat working again. Re-flashing didn't work but fooling around in the settings did work. The gimbal is now 180 degrees off (from the naza setting at about 135 degrees down with the naza unplugged... Strange) it's now stabilizing again. But I can't get the gimbal to turn to normal view. As you can see the pitch control doesn't make sense. It isn't even trying to bring pitch to zero. Calibrating didn't work.

    https://m.youtube.com/watch?feature=you ... bE9rGasA9Y

    Is there some setting I'm missing? (Invert?) I'm quiet new to this but I actually really enjoy doing stuff like this.

    Edit: this is what it's doing now. It looks like it's going to face forward but then keeps tilting back.
    Calibrating in different angles doesn't do anything.... It does accept the calibration.
    https://m.youtube.com/watch?v=-DkE5ii6a ... ata_player

    Another edit...:

    Well, A new controller including firmware... I think i'm just going to order one from ebay. Its just a little bit over 8 dollar.

    http://www.ebay.com/itm/BGC3-1-2-axis-C ... 2595fc07a1
     
  6. Tito

    Joined:
    Jan 19, 2015
    Messages:
    32
    Likes Received:
    1
    Location:
    The Netherlands
    Ok it's working again! I needed to invert top axis from Z to -Z. Now fine-tuning comes in. I've given the gimbal motors some extra power (about 60/70%) and now its a little bit stronger to resist agains the cables.

    Anyone care to share a screenshot of the PID setting of a stock chinese gimbal? 2.2b2 I believe this is a Alexmos board whatever that means.