Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

signal loss on my DJI Phantom 3 Pro

Discussion in 'Pro/Adv Discussion' started by cc151, Jun 7, 2016.

  1. cc151

    Joined:
    Jun 7, 2016
    Messages:
    3
    Likes Received:
    1
    So I bought a used Dji Phantom 3 Pro from my close friend who only sold it because he wanted to upgrade to dji phantom 4 and it worked perfectly when he sold it to me, the RC has a range extender antenna like this one
    (image from google)
    [​IMG]
    So the problem is like this: I can fly no problems normally but when the drone is under stress, like windy conditions or if I floor it in some direction I get a signal loss for a few seconds, I have tried flying 1.3km away with no problems with RC link stable but I always get signal loss (no video feed but full control of the drone with RC link) for a few seconds every now and then when I am flying, I have tried flying away from interference, in the forest 10km away from city

    maybe this is a firmware issue? thats my best guess, I hope you guys can help me, thanks.
     
  2. Reed L

    Joined:
    Sep 13, 2015
    Messages:
    1,261
    Likes Received:
    390
    Location:
    Alta, Ca.
    fw, yep... and lower the bit rate to 4 for a better signal because having it cranked up to 10 will cause loss also at longer distances..
     
  3. cc151

    Joined:
    Jun 7, 2016
    Messages:
    3
    Likes Received:
    1
    I think I have tried lowering the bitrate, I will try again today. But do you think the range extender antenna could cause this?
     
  4. Malster1

    Joined:
    Apr 4, 2016
    Messages:
    131
    Likes Received:
    35
    Location:
    Bay Area California
    I've been wondering why I get the same issue with that antenna too. Never dawned on me to lower the bit rate. I'm going to try your suggestion too.

    cc151: I have the same antenna and run into the video loss at time too, you really have to keep that pointed down range for long flights and try not to flight right above since the signal is directional 180 facing away from the panel. I fly over open water a lot and have had total loss of signal and control randomly at about 1000' away, but out at 2.5 miles it's solid. wind is always a factor, flying slower far out helps. Good luck, interested in what the cause/fix is for you too
     
  5. cc151

    Joined:
    Jun 7, 2016
    Messages:
    3
    Likes Received:
    1
    So I tried flying at channel 32 with 4 bitrate and it was okay'ish still got a few no signal's but rest of the flight was fine when I was just cruising slowly.

    But its pretty annoying that I cannot change bitrate in Auto mode, I have to have Custom and pick a channel in order to control the bitrate...
     
    Reed L likes this.