Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

should I update from 1.7.0060?

Discussion in 'Pro/Adv Discussion' started by wlkngmachine, May 14, 2016.

  1. wlkngmachine

    Joined:
    Jan 6, 2016
    Messages:
    22
    Likes Received:
    2
    Right now I'm on P3P 1.7.0060 and DJI GO v2.7.1. Not really sure how to figure out what my RC is but I updated it when I updated to AC1.7.......I usually go with the updates no problem, but I've been hearing a lot of questionable things about 1.8. Should I upgrade? Is 1.8.80 good to go with iOS? Thanks!
     
  2. MikeyOnline

    Joined:
    Apr 22, 2016
    Messages:
    338
    Likes Received:
    116
    I can't speak to iOS (I'm on Android) but 1.8.80 has been pretty flawless for me on my P3P as has the latest Go app which I believe is 2.8.0 for Android.

    Mike
     
  3. rockydog

    Joined:
    May 25, 2015
    Messages:
    882
    Likes Received:
    250
    Location:
    London UK
    IOS app is 2.8.1.....RC 1.6.....P3 1.8.80. All working well, and I haven't had any problems.
     
    jaseman007 likes this.
  4. Not A Speck Of Cereal

    Joined:
    Mar 8, 2016
    Messages:
    404
    Likes Received:
    145
    No problems here. That update came out quite awhile ago and most of us are on it, it seems.
     
  5. wlkngmachine

    Joined:
    Jan 6, 2016
    Messages:
    22
    Likes Received:
    2
    nice, thanks for your replies! Anyone else? I've been hearing that people were having video connection issues and that people weren't able to upgrade the RC. have those issues been solved? Thanks
     
  6. jaseman007

    Joined:
    May 2, 2016
    Messages:
    58
    Likes Received:
    13
    What he said.

    Jas