Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Sever drifting issue and no video feed, help please

Discussion in 'Phantom 2 Vision + Help' started by IndyJones1023, Jul 29, 2014.

  1. IndyJones1023

    Joined:
    Jul 14, 2014
    Messages:
    9
    Likes Received:
    0
    Location:
    Orlando, FL
    These seem to be common issues DJI is having, and I have them with my brand new Vision+. I've found some threads, and some fights, but am having trouble nailing down exactly what to do. I'm hoping it might be some loose wires or something. Is there an online walkthrough on what to check to remedy these problems?
     
  2. nintendrone64

    Joined:
    Feb 19, 2014
    Messages:
    353
    Likes Received:
    2
    Location:
    Simi Valley, CA

    What kind of drifting are you encountering?

    I mean, the Phantom in GPS will do it's best to hover in one spot, but it's a flying aircraft. It's going to be moving around, bumping between invisible lines to stay in the designated location. You can expect it to move around 1-3 feet from your GPS hover.
    Also, if you're flying too low to the ground, your craft will appear to be drifting because the blow-back of the props.
     
  3. IndyJones1023

    Joined:
    Jul 14, 2014
    Messages:
    9
    Likes Received:
    0
    Location:
    Orlando, FL
    I'll post a video, hopefully tonight. The drifting is bad. This isn't hover in place drifting. This is "where the hell are you going?" drifting. When the video feed worked for the first few flights I was averaging 9 satellites. Is that not enough?