Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Sept. 2016 firmware upgrade

Discussion in 'Standard/4k Discussion' started by LockJaw220, Oct 2, 2016.

  1. LockJaw220

    Joined:
    Aug 10, 2016
    Messages:
    18
    Likes Received:
    1
    So i recently updated my DJI GO app and yesterday I take my phantom 3 standard out to fly. I immediately noticed the look of the app was different. When I attempted auto take off, the command timed out 3 times before finally taking off so I proceeded with caution. The option to switch from photo to video was different and when I tried it there was a good 20-30 second delay before it switched. I also noticed that my R/C power light would occassionally blink from green to red. Today while trying to sort all of this out, I attempt to connect to phantom wifi and it says "no internet connection" when I attempt to connect. Also on the app in overall status it says firmware upgrade needed. I cannot find any threads related to this or a way to upgrade the firmware so any advice or direction would be greatly appreciated. Thanks!
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,117
    Likes Received:
    5,632
    Location:
    US
    That's just notifying you that you're connected to WiFi that's not connected to the Internet.

    Follow these instructions:

     
  3. LockJaw220

    Joined:
    Aug 10, 2016
    Messages:
    18
    Likes Received:
    1
    I don't know why but the app wasn't giving me the option to upgrade the firmware. Finally it gave me the option and I was able to successfully upgrade the firmware. It appears to have resolved the issues with the delays in recording and the auto takeoff command timeout. As for the no internet connection message, i've never seen that before but my app still connects to the device so I think all is well. Thanks for replying!
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,117
    Likes Received:
    5,632
    Location:
    US
    I'm assuming you're running an Apple device. If so, it was a recent change Apple made.
     
  5. LockJaw220

    Joined:
    Aug 10, 2016
    Messages:
    18
    Likes Received:
    1
    Yes, iphone 6. Thanks again for clearing that up.
     
  6. Squinly

    Joined:
    Oct 2, 2016
    Messages:
    34
    Likes Received:
    1
    Hey LockJaw, a few of us are experiencing the same issues, see the "extreme lag" thread. Seems to be related to the DJI 3.0.0 App on iOS. Question, what firmware are you running now? 1.6.8 or is there something newer out? Which country are you in? I.e. FCC (US) or CE (Europe/Asia) mode?

    I downgraded my firmware to 1.5.7+ a while ago because it fixed a different issue. I'm afraid to update again now in case something else happens!
     
  7. LockJaw220

    Joined:
    Aug 10, 2016
    Messages:
    18
    Likes Received:
    1
    I am in the US. I can't figure out how to see what firmware I upgraded to. If you can tell me how to find it I'll be glad to get back to you.
     
  8. Squinly

    Joined:
    Oct 2, 2016
    Messages:
    34
    Likes Received:
    1
    Connect your DJI Go App, in camera view, click the settings menu, then 'about' which is the bottom menu option. It should list the current firmware version there.
     
  9. LockJaw220

    Joined:
    Aug 10, 2016
    Messages:
    18
    Likes Received:
    1
    I checked there and it only shows me which version of the DJI go app i'm running.
     
  10. Squinly

    Joined:
    Oct 2, 2016
    Messages:
    34
    Likes Received:
    1
    Sorry, you have to be connected to the wifi of your drone with the bird and controller powered up
     
  11. LockJaw220

    Joined:
    Aug 10, 2016
    Messages:
    18
    Likes Received:
    1
    Thanks. It is version 1.6.80. I have yet to fly it since the firmware upgrade but was able to test the lag issues regarding the command timeout on auto takeoff and also the video/camera lag issue and they both appeared to be corrected. I'm hoping to get a flight in tomorrow after work. I'll let you know if I notice any issues after that. I'll check in on the "Extreme lag" thread also.
     
  12. Squinly

    Joined:
    Oct 2, 2016
    Messages:
    34
    Likes Received:
    1
    Thanks mate!
     
  13. LockJaw220

    Joined:
    Aug 10, 2016
    Messages:
    18
    Likes Received:
    1
    What issue were you having with V. 1.6.8?
     
  14. Squinly

    Joined:
    Oct 2, 2016
    Messages:
    34
    Likes Received:
    1
    I think it's mainly CE mode users who after updated to 1.6.8 noticed extremely bad range, I'm talking 20m-50m before the app would show weak transmission and ask you to activate fly home. It keeps popping up on the screen. the video cuts out too. Downgraded to 1.5.7+ and it was back to normal again!
     
  15. LockJaw220

    Joined:
    Aug 10, 2016
    Messages:
    18
    Likes Received:
    1
    ok. I flew today after work at a jobsite. All of the app issues seemed to be resolved. I got out to around 1650 feet when I began losing wifi signal. I don't know if that was due to the firmware upgrade or the fact that I was getting a strong interference warning. I will have to try flying again at a familiar location. I didn't get any weak transmission warning at all or message to activate return to home.
     
  16. Squinly

    Joined:
    Oct 2, 2016
    Messages:
    34
    Likes Received:
    1
    1650 feet is 500m and if you were in an area with interference running stock equipment, you should be happy with that!
     
  17. Alistair McCann

    Joined:
    Sep 25, 2016
    Messages:
    6
    Likes Received:
    0
    I was running 1.5.7+ and upgraded to the new ios app firmware last week. Upon powering up my Phantom 3S I was getting noises from the drone itself and the app on my iPhone 6S+ was not reaponding to certain inputs. The camera/video button would not respond, the view sd card contents button would show a black screen with 'ERROR' on the screen.

    I decided to bite the bullet and upgraded to 1.6.3 again and the app is nos running smoothly and the drone is acting normally again.

    I am yet to test to see if I am getting the range issues I was getting the last time I was running the 1.6.3 firmware but I have my fingers and toes crossed.