Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

SDK Follow Me Firmware Question

Discussion in 'Pro/Adv Discussion' started by tundrastruck, Aug 2, 2015.

  1. tundrastruck

    Joined:
    Jul 6, 2015
    Messages:
    72
    Likes Received:
    13
    Location:
    Iqaluit, Nunavut
    Just downloaded the 88 Meg SDK Firmware for the P3A so I can try POI and Follow-Me. How has this worked for everyone so far thats tried it? Will this work with the Autopilot software app? Is it fairly stable? Currently running the default 1.1.9 firmware.

    Also, if it doesn't work out, can I use the firmware rollback fix thats been going around? I've dowloaded all the necessary .BIN files needed just in case.

    Any advice or feedback is appreciated.

    Thanks,

    JD
     
  2. Miguel Silva

    Joined:
    Jul 4, 2015
    Messages:
    62
    Likes Received:
    28
    Yes, it will work with autopilot software.
     
  3. tundrastruck

    Joined:
    Jul 6, 2015
    Messages:
    72
    Likes Received:
    13
    Location:
    Iqaluit, Nunavut
    OK so I updated from 1.1.9 to the SDK Firmware 1.2.7 downloaded from the DJI developer site for the P3A.

    Should it not be 1.2.8?

    Also, I tried to apply the update to the controller but it wouldn't even start a firmware update.

    I performed and IMU, Gimbal and Compass Calibration and the Copter seems to be responding fine. Haven't flown it yet just fired up the motors no props.

    I fired up the auto pilot app and it just says searching for Phantom. I tried enabling IOC and Mutiflight Mode and switching the RC to F Mode and still nothing.

    it doesn't want to talk to the Phanotm.

    Any ideas what I am doing wrong?
     
  4. tundrastruck

    Joined:
    Jul 6, 2015
    Messages:
    72
    Likes Received:
    13
    Location:
    Iqaluit, Nunavut
    OK so not really getting any answers from anyone here. I assume the IOS latest version of Autopilot isn't compatible and there is probably a beta version that does work but can't get it.

    I've tried everything method I can to get my Controller to update. No go so i assume it already came with the latest firmware.

    Copter seems to be responding fine otherwise except I cannot get Autopilot to see the dang copter.

    Honestly any input would be appreciated. Someone tell me what i'm doing wrong?

    Thanks
     
  5. FRBEAR

    Joined:
    Jun 11, 2015
    Messages:
    33
    Likes Received:
    6
    The DJI firmware should work. Format a mini sad card and only put the .bin file on it. Put it in the P3 and turn it on. The RC should be off. When done take the card out and read the .txt file. If it worked it should read success. Mine had several fails in the file before the final success.

    The AutoPilot app needs to be the one you receive if accepted as a beta tester and you also need the beta version of IOS 9.

    Until the AutoPilot app gets released I'm using my Samsung tablet and DJI Ultimate Flight V 3 available on Google play. It has Waypoint and POI Working now. Follow me is still disabled by DJI.
     
  6. FRBEAR

    Joined:
    Jun 11, 2015
    Messages:
    33
    Likes Received:
    6
    Darn autocorrect. Should be SD card.
     
  7. tomtnt

    Joined:
    Oct 11, 2013
    Messages:
    211
    Likes Received:
    69
    try litchi - it has waypoint, POI, and follow-me working with the beta SDK... also has really cool VR FPV mode to use with google cardboard type goggles:

    Here's my follow-me:

     
    Raph, rowdyjim and acherman like this.
  8. tundrastruck

    Joined:
    Jul 6, 2015
    Messages:
    72
    Likes Received:
    13
    Location:
    Iqaluit, Nunavut
    Unfortunately I don't own any android devices. Not an Apple fanboy but I only have Mac computers, and iPads, iPhone LOL So I guess I have to wait.
     
  9. clkilljoy

    Joined:
    Apr 30, 2015
    Messages:
    133
    Likes Received:
    36
    Seems to be a problem with SDK not supporting IOS and the Advance. I would think the Advance and the Professional would have all the same firmware but apparently the camera is not the only differences with the two Phantoms.
     
  10. Miguel Silva

    Joined:
    Jul 4, 2015
    Messages:
    62
    Likes Received:
    28
    The SDK is suported in ios and p3advanced.
     
  11. clkilljoy

    Joined:
    Apr 30, 2015
    Messages:
    133
    Likes Received:
    36
    Finally! It was not for a long while. I can understand the wait on the IOS version, but not on the Advance, you would think all things would be equal other then the 4K camera.
     
  12. tundrastruck

    Joined:
    Jul 6, 2015
    Messages:
    72
    Likes Received:
    13
    Location:
    Iqaluit, Nunavut
    Yeah the SDK I downloaded was for the P3A, but still couldn't get Autopilot to see it. Sadly I ended up upgrading to 1.2.8 and will wait for the firmware and auopilot betas to be fully released. Right now it's flying fine it seems with 1.2.8.
     
  13. tomtnt

    Joined:
    Oct 11, 2013
    Messages:
    211
    Likes Received:
    69
    can i get your autopilot beta access since you can't use it? =)