Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Standard SD card Invalid

Discussion in 'Phantom 3 Help' started by ShadyMaple, Oct 15, 2015.

  1. ShadyMaple

    Joined:
    Aug 25, 2015
    Messages:
    17
    Likes Received:
    0
    Having a problem with SD card. Today we videoed, transferred footage, got 2 of 6 files moved then file corrupted error. Now card needs to be reformatted. I've had this occur twice. They have been Sandisk class 10 cards. Anyone else?
     
  2. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,414
    Likes Received:
    567
    Location:
    Sydney Australia
    Is this the original card that came with the standard??

    If not, your card could be a fake (they make a 4gig into a 32gig).
    If I purchase a card, I check to make sure its authentic before using it.
    On android, there is an app called SD insight. Just insert card and it will check validity.
     
  3. Milo223

    Joined:
    Oct 13, 2015
    Messages:
    15
    Likes Received:
    3
    I had a bunch of files get corrupted by using a digipower card reader. Read some reviews and found out it was a common problem with the reader I got. Not sure how you're transferring though so may not be applicable.
     
  4. ShadyMaple

    Joined:
    Aug 25, 2015
    Messages:
    17
    Likes Received:
    0
    Thanks. I'm going to try formatting thru the app.
     
  5. Simonb3526

    Joined:
    Aug 31, 2015
    Messages:
    124
    Likes Received:
    64
    I had this on a 64 gig card. Needs to be fat formatted. Can do in Windows but the large cards can causes issues.
     
  6. Jezzy

    Joined:
    Oct 16, 2015
    Messages:
    44
    Likes Received:
    6
    Location:
    Montreal, Canada
    I just installed a 64gb in mine. In Windows I formatted as ntfs. Popped it into the gimbal, said invalid sd card, proceeded in formatting it within the app, and all is working fine.
     
  7. Al Andison

    Joined:
    Nov 10, 2015
    Messages:
    3
    Likes Received:
    1
    Issue with my MicroSD today. Used successfully 2 days ago, 32GB, lots of space. Recorded 127.1Mb video (.mov file) with usual accompanying .srt file, which was only 3kb. Anyway .mov file would only play first 17 seconds of video then aborted. No error messages. What happened? I must have a corrupt file, so will re-format MicroSD(as FAT), does this make sense to those that have overcome such an issue?
     
  8. Jezzy

    Joined:
    Oct 16, 2015
    Messages:
    44
    Likes Received:
    6
    Location:
    Montreal, Canada
    See my list above.. I did this and all works fine now for 10 flights and counting.
     
  9. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    You have to be sure that you turn the video record off, before you power down the P3 or you will corrupt the file.
     
  10. Al Andison

    Joined:
    Nov 10, 2015
    Messages:
    3
    Likes Received:
    1
    Thanks, Jezzy. Have reformated and will give that a try.
     
  11. Al Andison

    Joined:
    Nov 10, 2015
    Messages:
    3
    Likes Received:
    1
    Thanks bobmyers. Oh, oh...guilty. Thinking back that is likely what I did --powered off before stoping video. My worst habit. Second worst is when I forget to start the recording before landing!
    Yikes. Must redo my pre-flight checklist in bold font.
     
    bobmyers likes this.