Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

S2 switch not controlling ioc..

Discussion in 'Phantom 2 Vision + Help' started by Basically, Jun 28, 2015.

  1. Basically

    Joined:
    Jun 28, 2015
    Messages:
    1
    Likes Received:
    0
    I got this drone a few days ago and after turning on NAZA mode, I'm having trouble getting ioc to work. All S1 switches work, but S2 is not. What can I do? Also, is there a way to set up manual mode to the S2 switch?
     
  2. N017RW

    Joined:
    May 2, 2014
    Messages:
    7,002
    Likes Received:
    1,936
    Location:
    Palm Beach Co.- FL
    If the switch is not working, as verified in the RCAssistant, it is typically a hardware problem with the switch itself.
    You can Google/YouTube for vids on how to replace it. (You may consider doing S1 as well while in there.)

    "Manual" mode can only be assigned to S1.
     
    Mako79 likes this.
  3. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,491
    Likes Received:
    605
    Location:
    Sydney Australia
    +1
    And also check in the Phantom assist app. After you enable NAZA, you will need to check the IOC box. Turning on NAZA only enablles = ATTI mode/Failsafe/Manual. Ticking the box then enables IOC.
     
  4. RoyVa

    Joined:
    Apr 10, 2015
    Messages:
    2,248
    Likes Received:
    454
    Location:
    Virginia
    Yep sounds like the IOC block in the assistant software was not checked. Go back and verify.
     
    #4 RoyVa, Jun 30, 2015
    Last edited: Jun 30, 2015
Loading...
Similar Threads - switch controlling ioc Forum Date
Controlling gimbal tilt with trim or a switch General Discussion Feb 5, 2014
Switching to a new DJI account General Discussion Today at 3:24 AM
Wish the System Had a 'Learning' switch. Phantom 4 Pro Discussion May 13, 2017
Switching from P Mode to Sport Mode problems Phantom 4 Discussion May 11, 2017
Question about switching controllers. Phantom 4 Pro Help May 11, 2017