Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Reverting from 3.0 to 2.0 question

Discussion in 'Phantom 2 Discussion' started by MrC, Apr 11, 2014.

  1. MrC

    MrC

    Joined:
    Mar 11, 2014
    Messages:
    469
    Likes Received:
    6
    Location:
    Surrey. UK
    Will it also downgrade the central board firmware to 1.0.1.24 from 1.0.1.25 that its on now?
     
  2. Sketch6995

    Joined:
    Apr 6, 2014
    Messages:
    95
    Likes Received:
    1
    Location:
    Colorado, Western Slope
    DJI says its possible but not recommended.
     
  3. MrC

    MrC

    Joined:
    Mar 11, 2014
    Messages:
    469
    Likes Received:
    6
    Location:
    Surrey. UK
    Really? Where/when did they say this? I read about them telling people there is a problem with 3.0 and then they put v2.0 back up on the download page.

    Lots of people going back to 2.0, just need to know if I can/should also revert central board firmware to 1.0.1.24. Please someone who has downgraded let me know.
    Thanks.
     
  4. Dynamic

    Joined:
    Apr 12, 2014
    Messages:
    7
    Likes Received:
    0
    is there any instruction on how and where to dwngrade, i just got my phantom and did the update and now it won't connect to any satellites and i can't fly it .

    since the update i can't get sats to connect. and i can't fix this error. i was told a BS response from DJI that their going to have a fix that night but that was three days ago

    [img]http://carbonephotography.smugmug.com/photos/i-mFs5KvM/0/L/i-mFs5KvM-L.jpg[/img]
     
  5. MrC

    MrC

    Joined:
    Mar 11, 2014
    Messages:
    469
    Likes Received:
    6
    Location:
    Surrey. UK
    To answer my own question, you CAN downgrade to 1.0.1.24.
     
  6. Dynamic

    Joined:
    Apr 12, 2014
    Messages:
    7
    Likes Received:
    0

    HOW ? i dl the older naza software but it doesn't recognize my phantom
     
  7. Jbrown83

    Joined:
    Feb 8, 2014
    Messages:
    51
    Likes Received:
    0
    I have had no issues whatsoever with 3.0. What is everyone worried about? Im not flying near any airports so that doesn't bother me.
     
  8. MrC

    MrC

    Joined:
    Mar 11, 2014
    Messages:
    469
    Likes Received:
    6
    Location:
    Surrey. UK
    Using the phantom 2 assistant v2.0, not the naza software.

    I know 3.0 is working for most but it was the fact DJI have told some people on the phone that a problem with flipping over is down to the v3.0 software. Then they suddenly put back v2.0 along with v3.0 on the download page. Also the extra no-fly stuff.

    I'm sure its probably fine but there is no reason for me to upgrade just yet.