Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 Firmware Returned P3P

Discussion in 'Firmware' started by JamesBandes, Dec 17, 2015.

  1. JamesBandes

    Joined:
    Jul 23, 2015
    Messages:
    112
    Likes Received:
    10
    I tend to upgrade my firmware to version 15 on my P3P and it bricked the phantom. I was getting an error about device not found. I sent it in and they repaired it very quickly and sent back it appears that they changed the camera and all is working well it appears they have upgraded their customer service it was actually very good
     
    sifu128 likes this.
  2. JamesBandes

    Joined:
    Jul 23, 2015
    Messages:
    112
    Likes Received:
    10
    I received it back. Looks like they replaced the entire camera. It has its new registration number on it and it's ready to fly. image.jpeg
     
  3. mknmd

    Joined:
    Aug 25, 2015
    Messages:
    23
    Likes Received:
    2
    Having the same issue with device not detected in the hidden files , maybe mines a hardware issue too
     
  4. JamesBandes

    Joined:
    Jul 23, 2015
    Messages:
    112
    Likes Received:
    10
    What is not detected if it's device [15] and device [08] and you have no camera image you need to send it to them. Mine took 3 weeks to get back and yesterday I upgraded to firmware 1.6 and now the video cuts out. It only has 6 hours of total flight time and it has an extra 2 year extended warranty on it. If they ask me to send it in again I will decline and sue them in court.

    If it is making a steady tone when you turn it on and devices are not found you need to send it in.