Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Replaced stock RC antenna - now loosing connection to easy

Discussion in 'Phantom 1 Help' started by borgeolsen, Apr 2, 2014.

  1. borgeolsen

    Joined:
    Apr 1, 2014
    Messages:
    8
    Likes Received:
    0
    I replaced my P2V RC antenna with a TP-LINK 2.4GHz 8dBi Indoor RP-SMA Antenna.

    Now I loose connection with the Phantom very often, it does not get as far as with the original antenna so I am really confused.
    I have tried more antennas also, but its about the same results on all of them.

    On my app it says "lost connection". And "returning to home will" follow if I cant connect again.
    My stock antenna broke when I removed it, so I cant put it back again.

    I have checked the connection made in the RC, and it looks okay. I have used a Mini PCI U.FL / IPX to RP-SMA Antenna WiFi Pigtail Cable Connector.

    Anyone know what could be wrong?
     
  2. borgeolsen

    Joined:
    Apr 1, 2014
    Messages:
    8
    Likes Received:
    0
    Re: Replaced stock RC antenna - now loosing connection to ea

    The problem was the "low quality" Mini PCI U.FL / IPX to RP-SMA Pigtail Cable Connector. I replaced them with high quality connectors and it worked like a dream!
     
  3. paulgrenga

    Joined:
    Mar 30, 2014
    Messages:
    61
    Likes Received:
    2
    Re: Replaced stock RC antenna - now loosing connection to ea

    I think I am having the same problem. How do you know the difference between a high & low quality mini PCI cable?
     
  4. FlyingFox

    Joined:
    Mar 1, 2014
    Messages:
    347
    Likes Received:
    11
    Location:
    Cheshire UK
    Re: Replaced stock RC antenna - now loosing connection to ea

    The Price.
    I also originally bought a rubbish chela UFL cable had the same issue.