Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Remote controler update

Discussion in 'Phantom 3 Help' started by Txmark117, Jul 4, 2016.

  1. Txmark117

    Joined:
    Jul 4, 2016
    Messages:
    5
    Likes Received:
    0
    I have successfully updated quad and remote but the "Overall Status" on my sreen keeps saying "Remote Controller Update Required" ???? Help, I'm down and its the 4th !
    P3X_FW_V01.09.0060
    Thanks in advance....
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,771
    Likes Received:
    5,524
    Location:
    US
    Which firmware versions do you see listed in the "General Settings" --> "About" section of DJI GO?
     
  3. Txmark117

    Joined:
    Jul 4, 2016
    Messages:
    5
    Likes Received:
    0
    Below is how it reads.

    App 2.8.1
    Version N/A
    Remote Controller N/A
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,771
    Likes Received:
    5,524
    Location:
    US
    Are those the versions you see when your remote controller and Phantom are turned on?
     
  5. Txmark117

    Joined:
    Jul 4, 2016
    Messages:
    5
    Likes Received:
    0
    I'm not sure, I am at work and only looked at my phone. I will check as soon as I get home and report back. Thank you.
     
  6. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,771
    Likes Received:
    5,524
    Location:
    US
    Okay. FYI, the firmware versions will only be displayed when your remote controller and Phantom are connected to DJI GO.
     
  7. Txmark117

    Joined:
    Jul 4, 2016
    Messages:
    5
    Likes Received:
    0
    Okay, so here is what it says
    App 2.8.2
    Version 1.9.60
    Remote Controller1.1.8
     
  8. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,771
    Likes Received:
    5,524
    Location:
    US
    Since your remote controller firmware is older than 1.3.2, you should install 1.3.2 using a memory card and then the latest version of the firmware using DJI GO. If needed, you can find detailed firmware installation instructions here.
     
    Txmark117 likes this.
  9. Txmark117

    Joined:
    Jul 4, 2016
    Messages:
    5
    Likes Received:
    0
    That worked great!
    Thank you so much!