Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Red Light on RC after update - but gone with Aircraft on

Discussion in 'Pro/Adv Discussion' started by Shep, Dec 24, 2015.

  1. Shep

    Joined:
    Dec 24, 2015
    Messages:
    110
    Likes Received:
    46
    Location:
    Phoenix
    First time posting (so be gentle :) )

    This is for my Phantom 3 Pro.

    Saw that there was a 1.6.04 update, so downloaded from DJI and followed instructions (watched linked video on DJI page - which seems to be wrong).

    Update to bird went fine. Video says to use the same .bin file on RC, but from what I can tell - that is no longer the case. The RC can be updated from the Go App. (Is that correct?)

    Went forward according to the video with the same 1.6.04 firmware - to install on the RC through the USB port (according to video). On power-on, the light turned red, no beeps and never turned off. Eventually I turned off RC and unplugged the USB flash drive.

    Now here is where I am a bit confused. App is 2.4.3, Aircraft is 1.6.04, and RC is 1.5.70 and I get no notices to update anything!

    However: When I turn on my Remote Control by itself - the far left LED is red - UNTIL I boot up the aircraft, then it goes away. I don't remember ever having that red light, may it was lit and I just don't remember.

    When everything is on and hooked up, (app included) - everything looks normal.

    Is that red light normal with the craft off? If not, any suggestions?

    Thanks ahead of time:
    Shep
     
    #1 Shep, Dec 24, 2015
    Last edited: Dec 25, 2015
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,116
    Likes Received:
    5,632
    Location:
    US
  3. Shep

    Joined:
    Dec 24, 2015
    Messages:
    110
    Likes Received:
    46
    Location:
    Phoenix
    Thanks msinger. Did you see my update version numbers? They all seem to be correct. I didn't really get an answer to the red light before I turn on the drone and a green after. Any advice on that? Are my version # correct?

    Thanks,
     
  4. Flying Dutchman

    Joined:
    Aug 23, 2015
    Messages:
    139
    Likes Received:
    41
    Location:
    Netherlands
    Hi Shep,

    The red light on the RC is normal with the Craft off and not connected. And your version numbers are correct as they should be. Al is good.
     
  5. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,116
    Likes Received:
    5,632
    Location:
    US
    Yes.
     
  6. Shep

    Joined:
    Dec 24, 2015
    Messages:
    110
    Likes Received:
    46
    Location:
    Phoenix
    Flying Dutchman - thanks for answering my questions. Msinger, also thanks for your help. I just did not remember that red light and it had me bugging' :)