Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Rear Indcator Light / Prop failure

Discussion in 'Phantom 2 Help' started by Knack, Apr 13, 2015.

  1. Knack

    Joined:
    Apr 13, 2015
    Messages:
    2
    Likes Received:
    0
    New pilot here. Flew my Phantom 2 last week put it away no crashes no probs. Took it out yesterday. Turned on Remote, then turned on Phantom. All 4 indicator lights flashed 2-3 times then both rear indicator lights went out. Picked up gps showing 2 front green lights only. Tried to see what would happen to start the props. Pulled down and in, all 4 props kicked in, i pushed up sticks and the two front props flipped it battery side up. All 4 props were spinning, only front two spinning enough to develop lift.

    Went thru and calibrated IMU basic and advanced, no change. Any ideas how to fix this? I have read in other posts that when they crash hard that the LED harness can unplug, not the case here, the leds come on when started for 2-3 blinks so they work..., it there a diagonstic download that i can figure WTH is going on?
     
  2. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,105
    Likes Received:
    404
    Location:
    Commerce Twp,MI
    I suggest you read the owners manual because apparently you don't know the front from the rear. The front LED's are always red never green and only when when props are running. Next to takeoff the left stick only is used for takeoff. You advanced both the left and right sticks forward at the same time causing the P2 to flip over.
     
  3. N017RW

    Joined:
    May 2, 2014
    Messages:
    6,239
    Likes Received:
    1,613
    Location:
    Palm Beach Co.- FL
    Plus One!
     
  4. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,105
    Likes Received:
    404
    Location:
    Commerce Twp,MI
    Thank you.
     
  5. TeamYankee

    Joined:
    May 30, 2014
    Messages:
    491
    Likes Received:
    42
    Location:
    Swansea, Wales, UK
  6. Knack

    Joined:
    Apr 13, 2015
    Messages:
    2
    Likes Received:
    0
    My error, let me restate this. When I start up I get three yellow flashes on the camera side LEDs(front) then they go out. My battery side (rear) will flash yellow until they find the GPS and flash green, while the front LEDs are still out. So I can guess that the wiring is ok to the front LEDs as they do in fact light, if all but briefly. So to get the props started pull down and in.. ALL props start. I release the sticks and they go neutral. When I then push up on the left stick the rear props lifts and rolls the drone onto the front props.

    So I spoke incorrectly, there is no stick error, I push left stick straight up. *** of drone rolls.
     
  7. CityZen

    Joined:
    Oct 22, 2014
    Messages:
    940
    Likes Received:
    36
    Location:
    NYC
    Can you hook the Phantom up to a computer, run the Assistant software, and verify that the controls (onscreen) behave as expected when you move the sticks?
     
  8. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,105
    Likes Received:
    404
    Location:
    Commerce Twp,MI
    Connect the RC to the software and check that it is in mode 2 then do a complete calibration. Next connect the P2 to the assistant software and make sure all the sticks are in normal and the same for X1 then calibrate the sticks again while the RC unit is on. If you have the P2 v2 with the tilt wheel on the upper left corner of the RC make sure to highlight upgrade transmitter version just under the sticks. Once all that is done do a IMU advanced calibration and you are done. Lastly calibrate the compass outside and you should be good to go.
     
  9. JG Montana

    Joined:
    Apr 22, 2015
    Messages:
    14
    Likes Received:
    0
    Check that you mounted the props. properly.
     
  10. Marlin009

    Joined:
    Dec 31, 2014
    Messages:
    1,091
    Likes Received:
    515
    Location:
    West Coast of Florida
    If they go on, they're proper.