Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional "RC requires upgrade"

Discussion in 'Phantom 3 Help' started by Australis5, Aug 8, 2015.

  1. Australis5

    Joined:
    Jun 16, 2015
    Messages:
    119
    Likes Received:
    34
    Location:
    FL
    I had a successful P3P upgrade to 1.3.20. Upgraded from Pilot to iOS GO 2.0 app. I'm now getting a mixture of compass calibration issues (was recently on vacation, and had done IMU calibration previously and it cleared these - haven't done it again since returned home, if location matters) - but more concerning is the RC upgrade. Since its saying it won't upgrade the RC firmware through the app, am I supposed to, in fact, upgrade it through USB? And if so, with what file? I tried the 1.3.20 file, but RC won't see it (guessing because its not for the RC, just the bird). Confused. Brief video of errors I am seeing below. Thoughts??

    https://www.dropbox.com/s/47siiebi6p33xks/IMG_1298.m4v?dl=0
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,871
    Likes Received:
    5,559
    Location:
    US
  3. Australis5

    Joined:
    Jun 16, 2015
    Messages:
    119
    Likes Received:
    34
    Location:
    FL
    That did it, thanks! Oddly, it still would not read the SD card via the reader directly into the controller. But, when I wired it to the P3P it worked... the RC must not like the reader (which is a newer Kingston USB 3.0 reader). Thanks again for the help!