Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 Firmware RC link failure after March 2016 P3P firmware upgrade?

Discussion in 'Firmware' started by KIWI, Mar 25, 2016.

  1. KIWI

    Joined:
    Dec 30, 2015
    Messages:
    9
    Likes Received:
    0
    After many successful flights, the other day I installed the latest firmware upgrade and Go App. It installed successfully, and before I took it to a park across the road to confirm it was all operational, I successfully recalibrated the compass, the camera gimbal, and the IMU. The GPS locked on 16 satellites. At the park I used the automatic takeoff button on the RC, letting it hover for a minute as recommended.

    Surprise, surprise, surprise... when I pushed forward on the left stick (altitude control - up), nothing happened. Nothing happened when I pulled back on the control to land. Pushing left and right on the left stick had no effect.
    Similarly the right stick control was not working. However, the automatic land button worked fine.
    I tried this several times but although the RC takeoff / land buttons worked, the joy sticks had no effect at all.

    In desperation, I re-linked the RC and went out to try again. Miraculously, it was all working again.

    I'm baffled. If the RC link to the Phantom was dead, how could the takeoff and landing button worked?
    Clearly, there is something I don't understand about the unit.
     
  2. garykeithmead1

    Joined:
    Nov 29, 2015
    Messages:
    259
    Likes Received:
    39
    Location:
    Uk
    Did you calibrate your r/c ?.
     
  3. KIWI

    Joined:
    Dec 30, 2015
    Messages:
    9
    Likes Received:
    0
    If by calibrate you mean "re-link" the RC to the Quadcopter, yes.
    What I don't understand is how the DJI Go App "takeoff/land" buttons worked if the RC was not able to communicate to the Quadcopter.
    Does a firmware upgrade "unlink" the RC connection?
    If so, why did the buttons in Go App work?

    Thanks
    Mike
     
  4. garykeithmead1

    Joined:
    Nov 29, 2015
    Messages:
    259
    Likes Received:
    39
    Location:
    Uk
    Recalibrate your sticks on the r/c.
     
  5. KIWI

    Joined:
    Dec 30, 2015
    Messages:
    9
    Likes Received:
    0
    Thanks, but I had already checked this and it did not change anything. .
    It appears that relinking the RC to the Phantom fixed the problem.
    That still does not explain why the takeoff/land buttons in the Go App worked, but the joysticks were not recognized. Aren't the buttons still dependent on a working RC link? That's the question still on my mind.
     
  6. Greywolfpa

    Joined:
    Mar 28, 2016
    Messages:
    1
    Likes Received:
    0
    Location:
    Pittsburgh PA
    Same here after firmware upgrade had to relink r/c to Phantom but notice litchi app work just fine
     
  7. KIWI

    Joined:
    Dec 30, 2015
    Messages:
    9
    Likes Received:
    0
    BUT why did the auto takeoff and land buttons on the RC controller work? They use the same communications link. That is the mystery I am looking to resolve.
     
  8. Suntana

    Joined:
    Jan 31, 2016
    Messages:
    165
    Likes Received:
    61
    Location:
    Jaffray, BC Canada
    That's messed up, the same thing happened to me but I never thought nothing of it until you mentioned it.


    Sent from my iPad using PhantomPilots mobile app