Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

RC LED is Green

Discussion in 'Phantom 2 Discussion' started by Bluegrass, Aug 24, 2014.

  1. Bluegrass

    Joined:
    Apr 8, 2014
    Messages:
    175
    Likes Received:
    0
    Does anybody know why the RC led is green. It was red. This is a new phantom that hasn't been flown yet. Upgraded 3.04 to 3.06 & installed Zenmuse H3-3D. I've gone through several calibrations on the phantom & the RC plus tried sync process to no avail. I've spent a day on this forum & working on the phantom but I can't:
    1. Get the RC led back to red.
    2. Can't get sync process to work.
    3. Can't get motors to start.
     
  2. riblit

    Joined:
    Mar 9, 2014
    Messages:
    118
    Likes Received:
    1
    Location:
    NSW, Australia.
    This is the LED on the RC transmitter?
    What is the operating frequency? Its written on the label on the back of the transmitter.
     
  3. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    Mine's a V+ but did something similar after one of the earlier updates.
    I calibrated the controller first - plug it in to computer and use RC program, then calibrated it again in the main assistant with cable into the Phantom.
    Rebooted everything and it was red again, all working normally.
    Not sure how this resolved it but easy to try and should be done periodically anyway.
     
  4. Bluegrass

    Joined:
    Apr 8, 2014
    Messages:
    175
    Likes Received:
    0
    Praise the Lord and pass the ammunition. I can't believe something that was undocumented in any manual anywhere seems to have been a problem I fought for almost 12 hours. I could shoot the documentation staff at DJI. In the RC Assistant software when doing a calibration on the transmitter, there is a place to choose mode 1 or mode 2. If you go through the calibration with the wrong mode chosen the led on the transmitter will turn green and you will no longer be able to start the motors. I need to go back through the calibration a couple times but I swear that id needed to be in one mode for firmware 3.04 and a different mode for firmware 3.06. At any rate I got the motor working and my red light back after choosing a different mode. These modes selections are not documented anywhere that I could find.
     
  5. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    Pleased you sorted it, don't go out and crash now though ;)