Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Rapid (Undesired) Ascending

Discussion in 'Phantom 2 Vision + Discussion' started by mattparker, Jan 29, 2015.

  1. mattparker

    Joined:
    Aug 8, 2014
    Messages:
    30
    Likes Received:
    1
    Dozens of successful flights in the past few months but during the last few, my P2V+ has decided to start ascending rapidly (example: from 20 feet to 100+ feet in seconds) after I back off the throttle completely, when flying forward in GPS mode at more than 50% throttle. Luckily it ascends, rather than descend. Obviously, something is not right. Who has experienced and how did you resolve?
     
  2. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,227
    Likes Received:
    914
    Location:
    Indy, USA
  3. phalcon51

    Joined:
    Jan 26, 2015
    Messages:
    66
    Likes Received:
    1
    Have they fixed this loose connector problem on the P2V+ v3 or do I need to open mine back up and do the tie-wrap repair?

    Thanks
     
  4. max

    max

    Joined:
    Sep 19, 2014
    Messages:
    199
    Likes Received:
    6
    As the saying goes, when you have a hammer every problem looks like a nail...

    OP, I don't know what this issue could be but I doubt it's loss of GPS. The barometer or other aspect of the IMU might be going bad?
     
  5. erikgraham

    Joined:
    Nov 4, 2014
    Messages:
    226
    Likes Received:
    9
    Location:
    New York and Philadelphia
    I would suggest checking your TX. You might have a bad stick.
    Try calibrating and see if it is cranked up. Be careful flying.

    If it's intermitant, it could be a loose connection inside the TX