Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced Question Regarding Firmware Updates

Discussion in 'Phantom 3 Help' started by MBusch, Sep 9, 2015.

  1. MBusch

    Joined:
    Sep 9, 2015
    Messages:
    1
    Likes Received:
    0
    Just bought a P3 Advanced on Amazon. It does not have any of the updates to the firmware installed. Do I need to install each in order (starting with the first update and finishing with the most recent update posted on 9/7) or can I just install the most recent update?
     
  2. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,751
    Likes Received:
    3,464
    From the top of the DJI download page:
    The All-in-One firmware v1.4.0010 does not include remote controller update package.
    However, for the best user experience, it is recommended that the users who are using the firmware that older than v1.3.20 to update the firmware to v1.3.20 before updating the aircraft.
     
  3. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,043
    Likes Received:
    5,608
    Location:
    US
  4. Memtenn60

    Joined:
    Dec 28, 2013
    Messages:
    118
    Likes Received:
    10
    I followed directions, and tried to install new firmware about 5 times. It will not install. I tried different SD cards and even downloaded from two different computers, still will not install. Do not get a txt file that says success or failure. I have updated previous updates with no problems and can't figure this out. I am scared to fly as the DJI GO app updated.
    Any suggestions.???
     
  5. bbfpv

    Joined:
    Feb 3, 2015
    Messages:
    3,745
    Likes Received:
    1,092
    Location:
    Long Island, NY
    put the .bin in the root.
     
  6. brasqo

    Joined:
    Jun 13, 2015
    Messages:
    18
    Likes Received:
    8
    Location:
    SC
    "The All-in-One firmware v1.4.0010 does not include remote controller update package.
    However, for the best user experience, it is recommended that the users who are using the firmware that older than v1.3.20 to update the firmware to v1.3.20 before updating the aircraft."


    This is what I had to do... Worked brilliantly.
     
  7. HarryPP3

    Joined:
    Jun 4, 2015
    Messages:
    11
    Likes Received:
    3
    If it doesn't include the controller update, then it says to install 1.3.2