Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Problems with H3 Black when connected to FPV Tx

Discussion in 'Phantom 1 Help' started by DaveT1, Jul 14, 2013.

  1. DaveT1

    Joined:
    Mar 3, 2013
    Messages:
    47
    Likes Received:
    0
    I've been trying to link my H3 Black to Fat Shark Predator FPV setup. My intial problems were linked to a bad USB socket on the camera. The camera was replaced under warranty and the new one syncs just fine. I took it out for a test yesterday and found that when the H3 was hooked up to the Tx, and still sitting on the ground, the goggles were showing a lot of snow. Once airborne, the there was no image on the goggles. The Phantom was no more than 50' from me.

    What would be causing the interference? I have the Tx mounted to the belly of the Phantom directly behind the H3, which works fine with the camera that came with the Fat Shark. The only thing that I have done that is out of the ordinary is that the connector cord I'm using has a lead for the camera and a lead for power input. I'm not using the power cord, so I coiled it and stowed it under the Velcro strap hold the Tx. Could that cause the interference?

    I'm a noob, so any help is greatly appreciated.
     
  2. jumanoc

    Joined:
    Jan 21, 2013
    Messages:
    700
    Likes Received:
    8
    Try setting your VTX / RX with another channel using small dip pins in VTX and control button on goggles.

    In addition, how are you powering the VTRX? directly from phantom wire?. I suggest you to use a FS filter designed for keep regulated voltage into VTX.

    [​IMG]
     
  3. GearLoose

    Joined:
    Apr 4, 2013
    Messages:
    475
    Likes Received:
    1
    I have the same set-up. As Jumanoc suggests, have you tried changing channels using the buttons on the goggles? (I didn't mess with the pins. I think this is only necessary when changing from the default channel.)

    Connect the balance lead from your Phantom battery to the filter -- see Jumanoc's image.
    Connect goggles to battery.
    Connect GPro cam with cable from Fatshark TX.
    Turn on GoPro.

    That should do it.

    BTW, I'm finding it much easier to use a small monitor than goggles. Sharper, brighter, clearer image. I like the goggles but don't yet trust my piloting enough to use them except in wide open spaces.
     
Loading...
Similar Threads - Problems Black connected Forum Date
Black Pearl and AVL58 Problems Phantom 2 Discussion Aug 7, 2015
Black Pearl problems Phantom 2 Vision Help May 24, 2015
Black Pearl and flysight 400mw problems FPV (First Person View) Mar 3, 2015
Setup Problems on my Black Pearl FPV (First Person View) Jul 13, 2014
Immersion RC and Black Pearl problems. Please help! FPV (First Person View) Jul 13, 2014