Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Problems using the forum, slow loading/page timeouts

Discussion in 'General Discussion' started by mrmcqueen, Feb 21, 2014.

  1. mrmcqueen

    Joined:
    Feb 16, 2014
    Messages:
    3
    Likes Received:
    0
    Location:
    Bromley, Kent
    Forgive me if this has been covered before, i'm new to this forum.

    When I click a link, any link, most of the time the page will take ages to load, if it loads at all. Many times it things about it for a minute or so then times out. Sometimes if I stop the page trying to load then hit refresh, it loads immediately.

    Is anyone else experiencing these problems, or just me? Is there anything I can do to improve the situation?

    It's incredibly frustrating, having all this info at my fingertips about my new hobby and not being able to browse it. I did try to use the search function, but I have the same problem, so it only seems to work about one time in five and then if it's not on the first page of results...

    It seems to affect me more on my mobile devices than PCs, but that could just be timeout configs in the different browsers.

    I tried to message a/the moderator rather than post on the open forum, but it seems I need to have been here a certain amount of time/have a certain number of post before I can use the PM functionality.


    Thanks,

    Adam
     
Loading...
Similar Threads - Problems using forum Forum Date
Is the 2.9.1 DGO GO Android App causing problems? Phantom 4 Help Sep 25, 2016
P3 Firmware P3 Pro RC firmware problems using iPhone 6S Firmware Aug 19, 2016
What firmware update is best? And problems with using follow me mode?? Standard/4k Discussion Apr 18, 2016
Software update causing problems??! Pro/Adv Discussion Aug 6, 2015
problems after doing firmware update using rotorpixel gimbal Firmware May 4, 2015