Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Problem with latest firmware upgrade

Discussion in 'Firmware' started by woodyshere, Jul 31, 2014.

  1. woodyshere

    Joined:
    Jul 31, 2014
    Messages:
    6
    Likes Received:
    0
    Let me say this first... I don't want ANYONE telling me "this topic has been covered already" if so, reply with a link to the appropriate response.

    I also need details on exactly how to do everything as the DJI website is so wishy washy it's unreal.

    Just upgraded main controller to 3.06. While it was doing it, my phantom started bleeping and lights flashing red. When I left it bleeping, it seemed to turn in to 4 bleeps with lights flashing sporadically.

    Assistant software said it upgraded fine but when I power cycled, the motors don't start up.

    When it's stationary and turned on, theres a green light followed by 3 red flashing lights.

    I read the release notes and it says at the bottom to upgrade the controller before the central board. Don't know if I did this!!

    If anyone has a fix or has any CLEAR instructions on how to roll back the update with LINK TO THE FILES I NEED that would be much appreciated!!!!

    Thank you in advance for your non sarcastic/unhelpful responses.
     
  2. srandall25

    Joined:
    Apr 17, 2014
    Messages:
    692
    Likes Received:
    4
    You say the motors no longer start? Are you sure your Tx is properly communicating with the Phantom? Maybe you just need to rebind the Tx to the Phantom. Another way to test comm between the Tx and Phantom would be to simply switch S1 from top to bottom 5 times (compass cal) and see if the Phantom responds by going solid yellow.
     
  3. jarrah31

    Joined:
    Jun 30, 2014
    Messages:
    64
    Likes Received:
    0
    Location:
    UK
    After the beeps and power cycle, did you plug the phantom back into your computer for more updates?

    When I upgraded mine I had to power cycle twice for 3 separate software upgrades (naza, main board, and one other I think).
     
  4. woodyshere

    Joined:
    Jul 31, 2014
    Messages:
    6
    Likes Received:
    0
    Thanks for your reply, I think I may have upgraded the wrong item first. The controller still connects, I can calibrate the compass after switching five times and the gimbal responds to input from the controller.
     
  5. woodyshere

    Joined:
    Jul 31, 2014
    Messages:
    6
    Likes Received:
    0
    And yes, I've tried power cycling and trying again with no joy. It doesn't even wait until the firmware is fully upgraded. It gets to about 7% then starts bleeping.
     
  6. wattage

    Joined:
    Jul 13, 2014
    Messages:
    264
    Likes Received:
    2
    Location:
    Scotland, UK
    If it's any consolation, mine started beeping during the firmware upgrade and didn't stop even after it was done. When I restarted and the P2V+ connected to the software, I got a CFG ERR message from the assistant which scared me as it was a very wordy yet vague error message. It went away after I calibrated the controller in RC Assistant. I hadn't tried to start the motors before I did this but IIRC what others have said here, recalibration of the controller needs to happen for them to 'unlock.'

    In Phantom Assistant, what firmware does it say you have at the moment?
     
  7. woodyshere

    Joined:
    Jul 31, 2014
    Messages:
    6
    Likes Received:
    0
    I'll try recalibrating the controller too see if it works.

    Main controller 3.06
    GPS 6.01.4
    receiver 1.0.1.3
    P330CB 1.0.1.32
    Zen IMU 1.0.0.4

    that's the firmware I have and it says its all up to date.
     
  8. woodyshere

    Joined:
    Jul 31, 2014
    Messages:
    6
    Likes Received:
    0
    Calibrated the controller, still no joy im afraid.