Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Problem Phantom 2 after chrash

Discussion in 'Phantom 2 Discussion' started by jvdmeer, May 20, 2014.

  1. jvdmeer

    Joined:
    May 20, 2014
    Messages:
    5
    Likes Received:
    0
    Hello,

    Last week my Phantom 2 crashed from 5 meter height during battery problem.
    It was full but after 2 minutes of flight I got a problem, try to land it but just some meters to short.

    Some part were broken and ordered some new one’s

    - Engine controle cables
    - iOSD mini cable
    - GSP antenna broken

    I replaced all, the GPS antenna soldered (got it from Ebay).

    When start unit PGS etc working oke, got 9 satellites as I read iOSD mini.
    But when going to flight it is unstable, not stay at position when I stop using remote.
    Is is drifting away and often it getting to the ground during flight(suddenly going meter lower).
    So need to give more power to get it up.

    So what is did was calibrating IMU unit but already this was looking oke and Check IMU status said no update needed(but used Basic Cali).
    This was not helping, have you got a solution for this?

    - Motor problem(one of them having problem)
    - Main CPE unit board not working, Gyriscope problem etc.

    Hope you can help we with this, before crach all was working perfect.

    Kind regards,
    Jelte van der Meer
     
  2. Kelso Kubat

    Joined:
    Oct 12, 2013
    Messages:
    299
    Likes Received:
    0
    Location:
    Frisco, CO
    post photo's.... :shock:
     
  3. mtpisgah

    Joined:
    Mar 11, 2014
    Messages:
    105
    Likes Received:
    0
    check body shell. (4) arms might not be align. and change props.
     
  4. jvdmeer

    Joined:
    May 20, 2014
    Messages:
    5
    Likes Received:
    0
    All, got tip that as mij unit fell down on top(where also GPS unit is placed) that some motors ar damaged.
    As i turn one arround i hear little metal sound, could this be the problem.
    Also when it is in the air you hear that is all the time try to get unit in line.

    Was already getting below one's and they are comming this week so try this first.

    http://www.multirotor.co/product_info.p ... cts_id=170

    Hope this solves my problem ......let you know the outcome
     
  5. goldfishrock

    Joined:
    Jan 7, 2014
    Messages:
    427
    Likes Received:
    0
    Location:
    Devon, UK
    I had a crash a couple of months ago and it took me weeks to get the bottom of the problems caused by it. Have you checked the motors for any sign of damage? One of the other members on this forum gave me some advice about checking motors.... just run your P2 up and throttle the motors up and down for a while, then shutdown and check each one with your fingers (or a laser thermometer) to see if one is significantly warmer than the others. This can indicate a problem.

    After many hours of going over my P2 I found one of my problems to be a cracked engine mount (something I discovered by chance). Take the top of the P2, hold each arm firmly in one hand and gently bend the motor one way and then another, all the time watching around the holes the motor bolts are located in. On mine I had two cracks that under normal circumstances weren't visible and only appeared when the airframe was genly maipulated. It's also worth checking the rest of the airframe using this method to look for any other cracks that may have propogated from weak spots.

    You may also want to check the GPS modile in the lid. The actual antenna has a ceramic ring around it which can sometimes crack upon impact if it's hard enough.

    The other problem I found was on the main board, it seems that one of the tracks that supplied motor power had lifted slightly under the solder joint meaning that in theory the +ve and -ve could have come together (albeit for a split second) which would be enough to cause majoy problems in flight.

    I the end my repairs were extensive. I had a new shell, new Main Board, 2 new ESCs and two motors.... but now it's back and happy. I hope you are able to get to the bottom of this Keep is posted hey?
     
  6. ianwood

    ianwood Taco Wrangler
    Staff Member

    Joined:
    Jan 7, 2014
    Messages:
    4,916
    Likes Received:
    1,792
    Location:
    Lost Angeles
    Replace the motor(s) that don't sound right or don't turn easily by hand. You can also feel them after you fly to see if they are hot to the touch. Then do an advanced calibration.
     
  7. jvdmeer

    Joined:
    May 20, 2014
    Messages:
    5
    Likes Received:
    0
    All,

    Thanks for the info, i have replaced the motors with MN2214-11 920KV to be sure.
    Also needed to replace the GPS unit, shield was broken.

    Now did going to fly again, all working but when going up or down the unit is vibrating.
    Can see on the movie screen the left side has that problem.
    As a see above that also the casing can have a problem I will check this also.
    Somewhere must be a problem, when just hovering, he is not steady with GPS positioning.
    It is little bit drifting, so did IMU calibration check tomorrow if this is helping.

    So any things I can check now than only casing?

    Regards,
    Jelte
     
  8. mtpisgah

    Joined:
    Mar 11, 2014
    Messages:
    105
    Likes Received:
    0
    im going in that direction. do you have video of how to replacing the phantom shell. thanks in advance.
     
  9. jvdmeer

    Joined:
    May 20, 2014
    Messages:
    5
    Likes Received:
    0
    Did do the follow, shell is comming tomorrow or next monday.

    - New GPS unit as mine was broken.
    - New T Motors
    - New propellers (carbon)

    At this moment when using more power is going to swig a bit.
    Looks like one engine getting more power….

    So just got new body, is this is not helping I send unit back to shop to let check it.
    Below my gain setting, got it from a web site.

    Pitch = 165 Attitute = 125
    Roll = 165 Attitude = 125
    Yaw = 185
    Vertical = 125

    Compass setting = x-10 y1 z-344 mod 1388

    So it is difficult to get this fixed, was oke but after it got down it is a mess.

    Regards,
    Jelte
     
  10. jvdmeer

    Joined:
    May 20, 2014
    Messages:
    5
    Likes Received:
    0
    Problem seems to be solved, did get last week a new body of the drone and now almost he flying perfect :)
    Only with the new T Motors needed to adjust the gain setting ....shaking like hell when going up to fast.