Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

possible solution to downgrade the firmware...

Discussion in 'Firmware' started by Andilama, Jun 20, 2015.

  1. Andilama

    Joined:
    Apr 25, 2015
    Messages:
    19
    Likes Received:
    2
    ...............edit
     
    #1 Andilama, Jun 20, 2015
    Last edited: Jun 20, 2015
    bobmyers likes this.
  2. steelegwds

    Joined:
    Jun 1, 2015
    Messages:
    8
    Likes Received:
    1
    Would be great to be able to downgrade
     
  3. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    Please please please
     
  4. Sammynels

    Joined:
    May 19, 2015
    Messages:
    586
    Likes Received:
    231
    Location:
    MA
    Anyone try this??
     
  5. keeny

    Joined:
    Apr 25, 2015
    Messages:
    50
    Likes Received:
    7
    Well if mine was bricked , I'd defo do it .
     
  6. n6vmo

    Joined:
    Feb 26, 2015
    Messages:
    484
    Likes Received:
    156
    Location:
    Lompoc, CA.
    I would really enjoy going back to 1.1.8....anyone brave enough to be the first to try this procedure?
     
  7. 2k3sgm

    Joined:
    Apr 27, 2015
    Messages:
    117
    Likes Received:
    34
    Who's gonna be first?.... Maybe the guy that did the CSC at 1600' to try and recover..
     
    Oso and Mal_PV2_Ireland like this.
  8. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    :)This may be a million dollar fix-- to get DJI off the hook:D and the the Phantoms back in the air. You never know until you try:cool: Im still on 1.1.9 and not changing until some positive posts are quoted
     
  9. tcope

    Joined:
    Jan 29, 2015
    Messages:
    3,556
    Likes Received:
    1,401
    Location:
    Salt Lake City, UT
    These instructions only mention downgrading (and upgrading) the transmitter, nothing about downgrading the P3 itself.
     
  10. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Read number 2
     
  11. jacky

    Joined:
    May 2, 2015
    Messages:
    21
    Likes Received:
    9
    Location:
    Tel Aviv
    Didn't work for me

    ========== 2014.01.01 00:00:15 remo-con disconnect======
    Packet: P3X_FW_V01.01.1003.bin
    Result: Abort.
    The firmware on the SD card is identical to or older than the current firmware on the aircraft.
     
  12. tcope

    Joined:
    Jan 29, 2015
    Messages:
    3,556
    Likes Received:
    1,401
    Location:
    Salt Lake City, UT
    You cannot install the dev firmware if you've done any updating of the firmware on the Phantom. This why there was a need to downgrade. Number 2 only contains information on _updating_.

    This is probably what jacky just encountered.
     
  13. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    So back to the unanswered question. Do we have a firmware programmer in the house?:) Or Maybe a DJI engineer who could post a reset?
     
  14. leekiya

    Joined:
    Aug 29, 2014
    Messages:
    1,103
    Likes Received:
    145
    Location:
    Lee. UK
    I'm sure another update will be coming soon as dji are well aware of the VPS and gimbal problems which are all over the 3 main forums and Facebook pages. I'm still on 1.9 and iOS 1.1.1 cos laggy video came about on 1.1.2. Not sure when I will be updating anything at this stage. I agree tho 1.8 seemed to be the most stable firmware so far.
     
  15. mosszaphod

    Joined:
    Aug 1, 2015
    Messages:
    4
    Likes Received:
    0
    Read Post #259 from the link below...use at your OWN risk...it will allow you to downgrade the Phantom 3 to Firmware 1.1.8 or 1.1.9. I also read it works with Professional and Advanced....on the other hand I also heard 1.1.8 is for Advanced and 1.1.9 is for Professional. Again, use the links and information I have posted here at your own risk, but I hope it helps a lot of people. I know this whole firmware thing has been a true nightmare!

    http://forum.dji.com/thread-23241-7...ZeU55MWpObUUyTFdFNU1XVXRZbVZpWVdFNVltRmxOVEZp
     
    #15 mosszaphod, Aug 1, 2015
    Last edited: Aug 2, 2015
  16. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,117
    Likes Received:
    5,632
    Location:
    US
  17. Palmieri

    Joined:
    Mar 22, 2015
    Messages:
    31
    Likes Received:
    1
    I downgrade succesfull but I dont know what firmware to use to update it again? Someone?
     
  18. Palmieri

    Joined:
    Mar 22, 2015
    Messages:
    31
    Likes Received:
    1
    Hi guys,

    I downgrade my RC succefully, but now I cant upgrade the firmware, can someone explain me how to do it or what firmware should I use? Please!!!!
     
  19. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,117
    Likes Received:
    5,632
    Location:
    US
    Install 1.3.2 on your Phantom, remote controller, and batteries. And, then install 1.4 on your Phantom only.
     
  20. Jase

    Joined:
    May 30, 2015
    Messages:
    84
    Likes Received:
    1
    Is it possible to downgrade from 1.4 to 1.2.6. I'm having video feed issues from when I upgraded and need to be able to carry on working for now until the issue is sorted out. When I upgraded to 1.4 I went from 1.2.6 and not 1.3.2.... could this be an issue?