Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Please help! - No Video Signal to FatShark

Discussion in 'Zenmuse H3-2D GoPro Gimbal' started by BlackBaron, Oct 16, 2013.

  1. BlackBaron

    Oct 16, 2013
    Likes Received:
    Hi all,

    I need some help with my setup.
    DJI F550
    Naza V1 - PMU V2
    Zenmuse H3-2D
    GoPro Hero 3 Black
    FatSharks Attitude

    Everything worked fine for a while but then I had trouble get the FatSharks to work - i had a black (lit up) screen - rebooted the copter a couple times and it worked again. Now there is no video signal anymore - The camera still records to the chip just fine.

    I tried to track down the issue - bought a new VTX (Immersion 600mW) because I thought it must be the VTX - but still no signal with the new VTX.

    I hooked up a LCD screen directly to the Zenmuse module and cannot get a signal out (that should work correct?) I am using the 3.5mm to chinch (RCA) cable.

    Does anyone has an idea what to do or how to check the video signal coming from the gopro - throught the 8pin cable to the GCU?

    Thanks in advance!

  2. jabatan

    Oct 2, 2013
    Likes Received:
    I had a similar problem at one time when I saw very bad static but could make out very faintly, some resemblance of the picture I was taking. It drove me crazy thinking that my Immersion TX was faulty. I then switch to Channel 2 on the Immersion TX board, rebooted my Fatshark Attitude, and everything came back online!
Similar Threads - Please help Video Forum Date
Video shaking with even intervals - need help please Standard/4k Discussion May 15, 2017
Please help, I don't want to lose my photos/videos General Discussion May 10, 2017
Video help, please Standard/4k Discussion Feb 12, 2017
Sluggish video, please help General Discussion Jan 6, 2017
hi i need help please i have red and white dots on my phantom 4 video General Discussion Nov 12, 2016