Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Phantom_3_Professional_Firmware_v1.4.0010__en

Discussion in 'Phantom 3 Help' started by LowRider, Nov 9, 2015.

  1. LowRider

    Joined:
    Aug 29, 2015
    Messages:
    6
    Likes Received:
    2
    Please, can someone help me, after many attempts my P3P can not update, and now i have no video signal on remote
     
    Poundofnuts likes this.
  2. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Information-- give us some details, what FW are you on, what are you trying to upgrade to, what have you done, is this your first upgrade?
     
  3. LowRider

    Joined:
    Aug 29, 2015
    Messages:
    6
    Likes Received:
    2
    Not my first update,
    On aircraft update fails, when turn on remote/App and craft on app says aircraft needs update, all works but no signal (video signal)
     
  4. TheRyanKing

    Joined:
    Nov 9, 2015
    Messages:
    1
    Likes Received:
    0
    I have the same problem, No video as well as no recognition of the SD Card, the card is formatted correctly, I've updated numerous times.
     
  5. Superfelix

    Joined:
    Nov 9, 2015
    Messages:
    1
    Likes Received:
    0
    Hello,
    I purchased the Phantom 3 5 days ago . I have a problem " NO SIGNAL " and the gimbal after 15 seconds of proper operation goes out . I also made a video of what happens .

    and the menu " aircraft status " does not tell me the remaining memory of the SD ... not read the SD. Were is the problem??
     
  6. Poundofnuts

    Joined:
    Jul 6, 2015
    Messages:
    208
    Likes Received:
    34
    Wow Bobmeyers, do you still think this isn't a widespread issue?
     
  7. Poundofnuts

    Joined:
    Jul 6, 2015
    Messages:
    208
    Likes Received:
    34
    Tons of us are having the same problem. Search the forums for "no signal", or read the latest DJI GO App reviews in the App Store. The latest update appears to break about 90% of customers phantom 3's video feed, but works for about 10% of the users like bobmeyers. We believe the issue is caused by the latest remote firmware not playing well with the latest versions of DJI GO as well as iOS 9. It's a little bit of a conundrum we have on our hands and DJI hasn't released a fix yet.
     
  8. Poundofnuts

    Joined:
    Jul 6, 2015
    Messages:
    208
    Likes Received:
    34
    Join the club, this is affecting the majority of people that try to upgrade now. Search the forums for "no signal" or read the App Store reviews for the latest version of DJI GO. I wish DJI release a fix sooner than later for this.
     
  9. Poundofnuts

    Joined:
    Jul 6, 2015
    Messages:
    208
    Likes Received:
    34
    Join the club, this is affecting the majority of people that try to upgrade now. Search the forums for "no signal" or read the App Store reviews for the latest version of DJI GO. I wish DJI release a fix sooner than later for this.
     
  10. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Widespread is relative-- to those posting on the forum and trying to find out the issue-- yes, there are issues with all of these although, as you can see, some get solved and some don't. So we cant drop all of them in the same bucket. If you look at most of the longtime members posting here as well as the moderators, I don't believe you will find any of them complaining about the FW upgrades.

    If there is a real issue, you would hear it from them first. Ok, conceded, there are those who are having issues and those may well be hardware related, maybe the wrong chipset or something else. If that is the problem, the bird needs to go back to DJI or a drone repair facility to be sorted out since the answer is not coming on this forum.

    I have stated this before-- I have not had one firmware upgrade issue that was the fault of DJI-- although I did have one with the first because I failed to follow the instructions posted. After I read and follow the instructions that was released with the upgrade-- that issue was resolved real quickly. For sure there are issues and that is why folks who don't belong to this forum come here asking questions. You are not going to read about the hundreds of thousands flying these drones who are not having these issues-- so IMHO, this is an issue but is not wide spread. Ask some of the "pros" here with the real experience.
     
  11. ebfoxbat

    Joined:
    Apr 21, 2015
    Messages:
    69
    Likes Received:
    10
    Have you tried redownloading the firmware in the past few days? The reposted 1.4.0010 fixed my "no signal" issue
     
  12. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Here is another @Poundofnuts
     
  13. Poundofnuts

    Joined:
    Jul 6, 2015
    Messages:
    208
    Likes Received:
    34
    Bobmyers, the amount of customers that have the "no signal" issue is totally unacceptable from a consumer standpoint. Since you think it's users not following instructions, how can you explain the masses of us that did follow the upgrade instructions and still have the problem? How do you explain the users that have opened up a brand new phantom 3 out of the box and have the "no signal" issue? They didn't even perform an update, so it's impossible to be user error. I spoke with DJI support twice last week and on both occasions, they stated that they are receiving more and more reports of "no signal" issues every day. Have you even read the reviews for the latest version of DJI GO on the App Store? There are 55 reviews and over 40 of them state that the latest updates broke their phantom. But nah, you insist that it's a tiny problem. Right, a tiny problem that's affecting over 80% of the users, according to the App Store reviews.
     
  14. Poundofnuts

    Joined:
    Jul 6, 2015
    Messages:
    208
    Likes Received:
    34
    I'll try it now, I didn't know there was a new firmware.
     
  15. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    What ever?? If 80 percent of the users are having issues, then that is an interesting statistic which I don't believe you can back up with a a qualified source. So that would mean about 800,000 Phantom users have firmware problems-- I can assure you that that is not the case-- not even close.
    Hope you can find a reasonable solution soon, who knows, it may be a fix that someone has already tried and it worked. Cheers:):)
     
  16. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Check this thread-- may work for you if you haven't tried it.

    No Video Feed and Non Responsive Gimbal - Fixed
     
  17. tcope

    Joined:
    Jan 29, 2015
    Messages:
    3,516
    Likes Received:
    1,387
    Location:
    Salt Lake City, UT
    Did you place firmware on the SD card?