Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom Wifi keeps losing connection on Galaxy S3

Discussion in 'Phantom 2 Vision Discussion' started by asifm76, Feb 25, 2014.

  1. asifm76

    Joined:
    Feb 25, 2014
    Messages:
    38
    Likes Received:
    0
    Hey guys I just got a Phantom Vision and took it out for its first flight tonight. LOVE IT! Except the Phantom wifi would connect and 30 seconds later some other wifi around would connect and I would lose my Phantom connection. How do I make the Galaxy S3 stay connected to the Vision? Please help!
    Thanks!
     
  2. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
  3. asifm76

    Joined:
    Feb 25, 2014
    Messages:
    38
    Likes Received:
    0
    Thanks!

    I had researched that option online already and it still would not allow me to stay connected to the Phantom wifi. I am not sure what else it could be. But its annoying that after 30 sec it drops and 2 min later it reconnects and 30 seconds later it connects.

    Any other assistance would be appreciated!
     
  4. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    Assuming you haven't done it then another option is to "forget" all other wifi SSIDs it has stored so the Phantom SSID is the only thing it has to look for.

    Beyond that it might be worth trying with another device if you can just to eliminate completely any problems at the range extender end . I run the android app but on a Nexus 4 and haven't had any connection issues at all - hopefully someone with an S3 will be along soon to give more insight.
     
  5. rnrnrn

    Joined:
    Nov 21, 2013
    Messages:
    49
    Likes Received:
    1
    It all does depend on what kind of software you have running on your S3 and which firmware version you have.

    Is it Android 4.3? Official Samsung update for your carrier or some rooted software?

    In any case you should check the following:
    1) settings / wifi / menu button / advanced - and there:
    - Network notification - off (just to avoid the search);
    - Passpoint - off (as above);
    - Keep WiFi on during sleep - Always (to avoid a disconnection);
    - Scanning always available - off (to avoid position searches);
    - Wi-Fi Timer - off

    2) switch off all location settings - and I do mean all of them - that way you avoid the system trying to find a working wifi network to establish your position.

    Try all this and see if it helps ;)

    Cheers!
     
  6. Seahorse

    Joined:
    Jan 17, 2014
    Messages:
    427
    Likes Received:
    0
    Location:
    Hampshire, UK
    Or get a new phone, Galaxy 5 is almost here, though I am waiting for the new HTC One tbh ..

    Sent from my HTC One using Tapatalk
     
  7. tahazcity

    Joined:
    Feb 17, 2014
    Messages:
    9
    Likes Received:
    0
    turn airplane mode on, then turn on wifi only, works for me.
     
  8. Erroneous007

    Joined:
    Feb 12, 2014
    Messages:
    42
    Likes Received:
    0
    I had the exact issue on my HTC one after updating the software. It appears that there is a new "feature" that if the connection doesn't detect internet access after 30 seconds it blocks that connection. Mine dropped after 30 seconds and then tried to reconnect after I closed the connect and tried to reconnect. Go into settings after that connection drops and then click on the connection. It asked my if I wanted to unblock the blocked connection. After I said yes, it worked fine from then on.
     
  9. Seahorse

    Joined:
    Jan 17, 2014
    Messages:
    427
    Likes Received:
    0
    Location:
    Hampshire, UK
    Not experienced that, but I am using AR ROM.

    Sent from my HTC One using Tapatalk
     
  10. nhoover

    Joined:
    Dec 11, 2013
    Messages:
    851
    Likes Received:
    182
    Location:
    Los Gatos, California
    I also use the S3 (Verizon version) and it works fine. I haven't had to do anything special to the settings to make it compatible with the P2V. It connects pretty fast and is reliable. I know this doesn't help you figure out the problem, but the S3 is a great phone to fly the P2V with.