Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom V2 Controller Question

Discussion in 'Phantom 2 Discussion' started by f1renz, Mar 18, 2015.

  1. f1renz

    Joined:
    Jun 30, 2014
    Messages:
    18
    Likes Received:
    2
    Hi,

    Just received my new P2v2 controller which I have connected to my P2. The camera now seams to be working and it is so smooth. So this means my old controller must have had a crap tilt leaver. Question I have is can you set up the controller to get the camera to face forwards or do you have to hold the scroll wheel as it self centres the camera on a 45 degree angle once I let the scroll wheel go. Thanks
     
  2. QYV

    QYV

    Joined:
    Apr 1, 2014
    Messages:
    1,814
    Likes Received:
    7
    Location:
    NYC
    In Phantom Assistant on the Basic / RC tab there is a setting for which type of controller you have: Basic or Upgraded

    On a BASIC (original, DJ6) controller, the X1 lever on the back was a "position" type input. 0 = straight down, 100= straight ahead, etc.
    On an UPGRADED (NDJ6) controller, the little wheel tells the gimbal "move up" or "move down", with more turn of the wheel meaning faster gimbal movement.

    If you have the newer style NDJ6 controller but the RC type still set to Basic in the software, it will act as you describe where the gimbal goes back to 45deg whenever you release the wheel.
    Plug in your Phantom to USB, run Phantom Assistant and set the controller type to Upgraded on the screen I described above (picture below) and it'll start working like it should with the new controller type.
    [​IMG]
     
  3. f1renz

    Joined:
    Jun 30, 2014
    Messages:
    18
    Likes Received:
    2
    Done this now its working crap. Very slow in the upward direction and jumps. Any ideas
     
  4. QYV

    QYV

    Joined:
    Apr 1, 2014
    Messages:
    1,814
    Likes Received:
    7
    Location:
    NYC
    yes - hook the USB Into your RC and run the RC Assistant and do a calibration. it doesn't specifically say to move the X1 wheel, but move it around anyway as you move the sticks.

    then plug the USB back into the Phantom, switch to Phantom Assistant, and do the stick and X1 calibrations you can see on my screenshot above. Once complete, you should be able to move the sticks and X1 wheel and see the little black hash marks move smoothly in the "sticks monitor" section
     
  5. f1renz

    Joined:
    Jun 30, 2014
    Messages:
    18
    Likes Received:
    2
    done it 3 times still getting the same result
     
  6. f1renz

    Joined:
    Jun 30, 2014
    Messages:
    18
    Likes Received:
    2
    When doing the calibration under the RC assist, the screen shows it working fine. When I do it on the P2 it bounces around.
     
  7. QYV

    QYV

    Joined:
    Apr 1, 2014
    Messages:
    1,814
    Likes Received:
    7
    Location:
    NYC
    well now I'm out of ideas. the answer to the original question is indeed basic / upgrade setting. why it's not working in practice after that... you say the little black hashmark moves smoothly in the assistant software?
     
  8. f1renz

    Joined:
    Jun 30, 2014
    Messages:
    18
    Likes Received:
    2
    in the RC one yes but not under the Assist.
     
  9. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,409
    Likes Received:
    567
    Location:
    Sydney Australia
    remove the RC assist and reinstall.
    Then do calibrations as per QYV. Make sure you move the sticks and then move the tilt dial SLOWLY up and SLOWLY down.

    Also, goto ADvanced > Gimbal and make sure Gains = 5, Vert=0 and Horizontal=0. This adjust movement range.
     
  10. f1renz

    Joined:
    Jun 30, 2014
    Messages:
    18
    Likes Received:
    2
  11. QYV

    QYV

    Joined:
    Apr 1, 2014
    Messages:
    1,814
    Likes Received:
    7
    Location:
    NYC
    wow, that's a first for me but I'm glad you got it working!