Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom v2 beeps no lights

Discussion in 'Phantom 2 Vision Help' started by markstoys, Aug 6, 2015.

  1. markstoys

    Joined:
    Mar 29, 2015
    Messages:
    236
    Likes Received:
    19
    Hi my phantom vision just beeps no light on won't connect to computer it all started when I installed a aftermarket Chinese gimbal burnt that little resistor so I replaced the center board thinking that was the problem nope still beeps won't connect to pc hope someone can help
     
  2. markstoys

    Joined:
    Mar 29, 2015
    Messages:
    236
    Likes Received:
    19
    Follow up I did the hard relearn where you ground f1 to f2 in can connect to pc updated firmware lights work as they should but still beeps pushed button under pv2 to bind controller won't bind when I disconnect f2' lights as it should but when I plug it back in I loose lights .while its blinking all 4 motors twitching with the beeps I think I need a new flight controller
     
  3. markstoys

    Joined:
    Mar 29, 2015
    Messages:
    236
    Likes Received:
    19
    :)
     
    #3 markstoys, Aug 7, 2015
    Last edited: Aug 9, 2015
  4. markstoys

    Joined:
    Mar 29, 2015
    Messages:
    236
    Likes Received:
    19
    Does anyone think its a bad flight controller
     
  5. markstoys

    Joined:
    Mar 29, 2015
    Messages:
    236
    Likes Received:
    19
    Thanks guy's
     
  6. markstoys

    Joined:
    Mar 29, 2015
    Messages:
    236
    Likes Received:
    19
    :)
     
    #6 markstoys, Aug 8, 2015
    Last edited: Aug 9, 2015
  7. Marlin009

    Joined:
    Dec 31, 2014
    Messages:
    1,091
    Likes Received:
    515
    Location:
    West Coast of Florida
  8. N017RW

    Joined:
    May 2, 2014
    Messages:
    6,239
    Likes Received:
    1,613
    Location:
    Palm Beach Co.- FL
    Are you sure of your connections at the FC?

    The USB plugged into the LED port, correct???
     
  9. markstoys

    Joined:
    Mar 29, 2015
    Messages:
    236
    Likes Received:
    19
    OK after 20 hrs its working I did a hard start reprogrammed flight controller everything is working all except when I plug in. Gimbal servo to f1 on controller starts to beep non stop I unplugged it everything works normal so has anyone ever ran into this issue maybe f1 side of controller is bad ???
     
  10. markstoys

    Joined:
    Mar 29, 2015
    Messages:
    236
    Likes Received:
    19
    I wonder if I have to add firmware since I reloaded the controller ?
     
  11. markstoys

    Joined:
    Mar 29, 2015
    Messages:
    236
    Likes Received:
    19
  12. markstoys

    Joined:
    Mar 29, 2015
    Messages:
    236
    Likes Received:
    19
    Wth ??
     
  13. markstoys

    Joined:
    Mar 29, 2015
    Messages:
    236
    Likes Received:
    19
    Just a follow up I replaced servo that was the fix plugged the new one in worked good advise leave alone do not add Chinese gimbal that's when all my problems began first lost power to fc200 camera in turn burnt resistor on board replaced center board then burned Hi tec servo I did allot of research on my own ( no help here that's OK still love you guys ) then I did a hard reset just kept on beeping no communication with pc so this may help my fellow members. Oh thanks j dot for the naza wiring