Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom - Ratching Motor Sound

Discussion in 'Phantom 1 Help' started by iflynavy, Jul 16, 2013.

  1. iflynavy

    Joined:
    Jul 16, 2013
    Messages:
    2
    Likes Received:
    0
    Hello Everyone.

    Hard a hard landing yesterday, essentially from about 5-10m the engine just cut out. However it started backup and flew. I noticed the LED status was out so I took it a part last night to see if I could find out why, turns out the red wire was popped off the LED. After attempting to solder it I realized there was not metal for it to stick to and ordered a replacement.

    NOne the less put it back together went to start it up and now all 4 motors are making a ratching sound. I can't figure out why they would be doing that and with power applied nothing.... same slow twitching sound.

    Any ideas? IS there a way to get error codes without lights?
     
  2. TickTock

    Joined:
    Mar 31, 2013
    Messages:
    171
    Likes Received:
    1
    Do they turn freely when the Phantom is off? You may have gotten some bits of sand or gravel underneath the motor during your crash.
     
  3. iflynavy

    Joined:
    Jul 16, 2013
    Messages:
    2
    Likes Received:
    0
    Perfectly freely. Smooth as a babies bottom :)

    I also just took out a DX8 Reciever and bypassed the onboard one to see if it was something there and even with the DX8 and it's reciever, same thing.

    Oddly enough just to get a repaired LED you also get the MC Board.... the thing is it costs $60 and even though it will probably be here tomorrow, I'm wouldn't want to try that persay if that wasn't potentially it... but what are the odds all 4 ESCs are shot?