Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom motors spin backwards

Discussion in 'General Discussion' started by kenskid, Dec 1, 2013.

  1. kenskid

    Joined:
    Aug 3, 2013
    Messages:
    146
    Likes Received:
    1
    Hello,

    Just finished installing AR8000 with spectrum AR8000 RX - All looks good after a few minor setbacks. However, when putting it all back together and after calibration, I see that all four motors are spinning backwards.

    I did not change the motors or even take them out.

    Did I put one of the Phantom connectors back in wrong? I did have to take the two connectors off the top of the naza. One is for the LED and the other for the GPS. I reconnected the same.

    Any ideas?

    Thanks
     
  2. kenskid

    Joined:
    Aug 3, 2013
    Messages:
    146
    Likes Received:
    1
    Hey thanks for the reply. I'll check that out but I don't think I messed up the cover orientation. When I took it apart, I didn't fully disconnect the cables on the top of the phantom. It was a tight workplace and Im pretty sure that top would only go on one way because of the short cables.

    I'll check and let you know. I HOPE YOU ARE RIGHT!

     
  3. kenskid

    Joined:
    Aug 3, 2013
    Messages:
    146
    Likes Received:
    1
    DUDE! I didn't want to break down the Phantom again only to be wrong so I looked up some photos I had taken last week. Guess what? The decal locations in the photos are different than what I currently see on the Phantom. Got my tiny wrench and screwdriver in my hand.....I'll let you know!

    You da man!!!1

     
  4. SCADAMON

    Joined:
    Aug 2, 2013
    Messages:
    65
    Likes Received:
    9
    It is very easy to get the top back on 90 degrees clockwise or counterclockwise with out disconnecting the cables.
     
  5. kenskid

    Joined:
    Aug 3, 2013
    Messages:
    146
    Likes Received:
    1
    Thanks all - I did have it at 90 degrees.

    ....now here comes the Big Hairy But.....but then when I tested, my right and left were mixed up.(opposite). My forward and backward were ok. I went back in to the assistant and just "reversed" the controls. Now it works right. However, I know that I must have something wrong. Reversing the controls just covers up the error, no?

    Also, I can't seem to get the Phantom off of CL - course lock.

    Sorry for the simple jargon....I don't know all the terms...but I can fly the hell out of the Phantom.