Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom FC40 Drifting As If No GPS

Discussion in 'Phantom FC40 Help' started by funtimegrandpa, May 31, 2014.

  1. funtimegrandpa

    Joined:
    Mar 1, 2014
    Messages:
    98
    Likes Received:
    6
    My Brother had his FC40 get wet, This is what it is doing and will also tell you what I have replaced. It looks to lock on gps just fine, but once in the air it will not stay put. it will start to head forward and it is difficult to control. If I switch it to Atti I have much better luck, but it is as if the gps is messed up. All updates and calibrations have been done. I have exchanged the GPS, Compass, all Motors and ESC, also switched out the NAZA M V2 and it still does it ! the only parts left that have not been replaced are the 5.8G Receiver board which I can not find anywhere and the power board. I am hoping someone has some insight on what might be happening.
     
  2. CarlJ

    Joined:
    Feb 24, 2014
    Messages:
    782
    Likes Received:
    19
    Location:
    Peru, Indiana
    I had a compass issue that did that with my FC40, but you said you've already replaced that. My second guess would have been the Naza, but yeah...replaced.
     
  3. EMCSQUAR

    Joined:
    Sep 5, 2013
    Messages:
    1,692
    Likes Received:
    6
    Location:
    N 44.895 W 93.354 Minnesota
    Go into assistant software - >Basic -> Aircraft - make sure "Quad Rotor X" is selected. Then go to Tools, upload/restore default settings. Then do stick cal, Advanced IMU cal, then compass dance.
     
  4. nager36

    Joined:
    Sep 11, 2014
    Messages:
    1
    Likes Received:
    0
    I Have this issue with mine. Had it back to the shop who replaced GPS board. Still the same. Did you get this resolved, I would like to know.
     
  5. Colin70

    Joined:
    Nov 28, 2014
    Messages:
    30
    Likes Received:
    0
    Wondering if anyone figure out the issues listed here on this post? I have a very similar problem but not related to water. I checked motors and could feel a ruff turning motor so I bought a OEM motor from local hobby shop and replaced it. I have had really bad control of the phantom and a couple of fly aways due to this issue. I then had a motor stop working while on the table bench testing.I replaced all 4 with a upgraded motors. After replacing the motor one would not run. It turned out to be a bad speed controller. I ordered a new one and replaced. I discovered the phantom frame was cracked so I scratched the whole frame and replace it all onto a 450 platform. After much research on gps placement I got it all back together to discover it still drifts to the right in gps mode. It responds to low level controls pretty well in attitude mode. So I really need some advice on what in the heck to replace now. I have done multiple imu calibrations, compass dance, compass reading are as they were in the OEM frame. I adjusted the gps measurements for center of gravity. I have flown it at all zeros and offset measurements of C.G. On take off it has tipped over on a slow rev up.If I remember correctly it did start this stuff when I went to a wide landing gear. I did go back to the old landing gear after it started this wondering effect. But I might not have put it back in the right place possibly. I was thinking of replacing the gps and compass with a different version to ride me of this compass possibility? Any ideas?
     

    Attached Files: