Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

PHANTOM CONNECTION BROKEN

Discussion in 'Phantom 2 Vision + Help' started by Rodrigo, May 17, 2015.

  1. Rodrigo

    Joined:
    May 17, 2015
    Messages:
    2
    Likes Received:
    0
    Hi guys,
    Does any off you experienced this??
    My Phantom 2 V+ 3.0 was working perfect, then yesterday was about to fly it and this "PHANTOM CONNECTION BROKEN". I was connected to the WIFI extender but I have no image at all. However the camara still can be moved with the control. I rum my app from my samsung note 4
    I tried already to:
    1) uninstall and reinstall the app
    2) update the Phantom firmware
    3) tried 2 others devices (another samsung note 4 ans an iPad mini)

    Any of you have any idea on how to solve this issue? PLEASE HELP!!
     

    Attached Files:

  2. Rodrigo

    Joined:
    May 17, 2015
    Messages:
    2
    Likes Received:
    0
    if this happens to you... DEBIND your camera!!!
     
  3. roberto33

    Joined:
    Apr 3, 2015
    Messages:
    4
    Likes Received:
    0
    hi rodrigo.how do you debind camera please.
     
  4. RoyVa

    Joined:
    Apr 10, 2015
    Messages:
    2,246
    Likes Received:
    449
    Location:
    Virginia
    I would turn off the smart network switch. it could cause your Wifi to keep jumping around for the best signal therefore dropping the Phantom at times.
     
  5. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,409
    Likes Received:
    567
    Location:
    Sydney Australia
    (Once again) If you have crashed, then check the 3 grey cables coming down from the phantom to the gimbal board. Unplug all 3 and inspect, and double check the 4 pin-clip in grey cable. this is most likely the culprit. Plug back in and make sure all the cables are seated firm.