Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom Beeps once per Second, no LED's. help?

Discussion in 'Phantom 1 Help' started by smidge20, Aug 28, 2013.

  1. smidge20

    Joined:
    Aug 28, 2013
    Messages:
    1
    Likes Received:
    0
    hi guys, got a good sucessful first flight out of the Phantom

    Charged the battery, went to take it for its 2nd flight and plugged it in. The phantom just started beeping once a second.

    This indicates a firmware problem from what i have read in other topics and forums, but nothing changed after that first flight so i'm really confused as to what might have caused it?

    The laptop won't see it, the lights blink on briefly (the ones under the ESC's) and then it just sits there and beeps constantly.

    any help would be greatly appreciated!!
     
  2. erkme73

    Joined:
    Jan 4, 2014
    Messages:
    132
    Likes Received:
    63
    Smidge, did you ever get resolution to this issue?

    I have the exact same problem. Powers up for about 1 second, hear the standard chime, then all LEDs off, and beeping from all four arms at 1 per sec.
     
  3. erkme73

    Joined:
    Jan 4, 2014
    Messages:
    132
    Likes Received:
    63
    Well, that didn't take long. I ended up removing the cover, and found that one of the motors had lost the retaining c-ring on the bottom of the shaft. That ring held on a small brass spacer. Apparently, that spacer went roaming around inside the unit, and ended up shorting something out. When I turned the whole thing upside down and shook it, it fell out, and the problem resolved.

    Since day one, I've heard something loose inside (like a loose screw), but didn't want to take it apart right away (warranty?). Got it for Xmas a week ago, and couldn't see myself taking apart a brand new unit. Oh well. Lesson learned.