Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Standard Phantom 4K Edition UMI Problems

Discussion in 'Phantom 3 Help' started by Stanley Fredriks, Jan 14, 2016.

  1. Stanley Fredriks

    Joined:
    Jan 14, 2016
    Messages:
    19
    Likes Received:
    2
    Hi, I have some problems with my P3 4K edition. it will not IMUCalibration for some reason when i press IMU Calibration the progress will not work stay at 0% without any movement to calibration. i don't know what happen? i try everything but nothing helps i got this drone yesterday.

    If someone can tell me how to fixed.

    Thank you!

    Cheers, Stanley
     

    Attached Files:

    #1 Stanley Fredriks, Jan 14, 2016
    Last edited: Jan 14, 2016
  2. droneshop

    Joined:
    Mar 23, 2015
    Messages:
    125
    Likes Received:
    29
    Location:
    Calgary, AB
    How long do you leave it for? many times it will show 0% until the aircraft warms up enough, it is actually calibrating but will not show until the comuter is warmed up.
     
  3. Stanley Fredriks

    Joined:
    Jan 14, 2016
    Messages:
    19
    Likes Received:
    2
    Correction. I have leave it 25 min. But on the screen said "IMU calibration is in progress. please wait" but nothing will happen after that time. U mean i have to wait much long when is more warmed up? Thank for your help.
     
    #3 Stanley Fredriks, Jan 14, 2016
    Last edited: Jan 14, 2016
  4. droneshop

    Joined:
    Mar 23, 2015
    Messages:
    125
    Likes Received:
    29
    Location:
    Calgary, AB
    turn it all off, cool it down to 10 degrees celcius and try again.
     
  5. Stanley Fredriks

    Joined:
    Jan 14, 2016
    Messages:
    19
    Likes Received:
    2
    I did what u told me, but still doing nothing IMU Calibration.