Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 3 With iPod Touch 5th Gen

Discussion in 'Pro/Adv Discussion' started by Nick, Apr 8, 2015.

  1. Nick

    Joined:
    Apr 8, 2015
    Messages:
    17
    Likes Received:
    0
    Will the Pilot app ever work with the iPod Touch 5th Gen or do I have to by a new device to go with my drone? Please tell me they will develop the app to work with the iPod Touch!
     
  2. Mal_PV2_Ireland

    Joined:
    Mar 4, 2014
    Messages:
    2,589
    Likes Received:
    1,230
    Location:
    Dublin Ireland
    Have you not got an iPhone or android phone or tablet to use with it?
     
  3. Nick

    Joined:
    Apr 8, 2015
    Messages:
    17
    Likes Received:
    0
    No. I have an iPod touch 5th gen. Will it work?
     
  4. FASTFJR

    Joined:
    Nov 7, 2013
    Messages:
    1,199
    Likes Received:
    169
    Location:
    South East PA

    If its not on the list I wouldn't count on it. You can buy a refurbished iPad mini 2 for $249