Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Phantom 3 going crazy after firmware update

Discussion in 'Phantom 3 Help' started by PaulWall, Aug 24, 2016.

  1. PaulWall

    Joined:
    Aug 24, 2016
    Messages:
    4
    Likes Received:
    0
    Long story short, P3 was working great when put on the shelf several months ago. Got it out today in to prep everything for a flight on Monday and wouldn't connect to DJI Go app after updating. Then updated firmware with the latest from DJI website. Everything was appeared to be done and got the success txt file. While sitting for a bit still not able to connect to the app, the camera began to go crazy. I decided to switch back to the older version of firmware. I inserted the sd card with the older version and the thing started producing what sounded like a fire alarm. The P3 is scheduled to fly Monday and don't have time to send it to DJI for repair (their solution to the problem). P3 has never been crashed and only been used two times. Can some one please help me or anyone located around Jackson Ms that could fix this thing ASAP?
     
  2. PaulWall

    Joined:
    Aug 24, 2016
    Messages:
    4
    Likes Received:
    0
    After reading some, I finally just let the firmware reinstall with the gimbal going crazy and the fast beeps. Once the firmware was complete, the gimbal was still moving around like crazy but no more fire alarm type beeps. Any ideas?
     
  3. PaulWall

    Joined:
    Aug 24, 2016
    Messages:
    4
    Likes Received:
    0
  4. PaulWall

    Joined:
    Aug 24, 2016
    Messages:
    4
    Likes Received:
    0
  5. Dronason

    Joined:
    Aug 9, 2015
    Messages:
    498
    Likes Received:
    82
    Location:
    Switzerland
    Maybe try to see if the screw bellow is tight.
    Capture.PNG
     
  6. Dronason

    Joined:
    Aug 9, 2015
    Messages:
    498
    Likes Received:
    82
    Location:
    Switzerland
    I just tried on mine but the camera act not the same way as your when the screw is not tight, sorry.
    Did you have connection with the tablet ? If yes try to do a gimbal calibration.
     
  7. Darren66

    Joined:
    Jul 1, 2016
    Messages:
    1
    Likes Received:
    0
    Hi updated my firmware but left the nd filter on which unbalanced the camera. just checking you hadn't done the same thing?


    Sent from my iPhone using PhantomPilots
     
  8. goom2003

    Joined:
    Aug 27, 2016
    Messages:
    8
    Likes Received:
    0
    Same problem to me after update firmware on p3s to 1.6



    Sent from my iPhone using PhantomPilots
     
  9. Dronason

    Joined:
    Aug 9, 2015
    Messages:
    498
    Likes Received:
    82
    Location:
    Switzerland
    You are right, Some ND/PL filters are more heavy than the UV filter from DJI and require more current to the motors to keep it in place. Maybe good to try with the original one.
     
  10. sfazzina

    Joined:
    Aug 27, 2016
    Messages:
    29
    Likes Received:
    3
    The power of Christ compels you....The power of Christ compels you !!!!

    Omg. Looks possessed!!!

    Sorry man. I feel bad for you.
    Do you have a friend that has the same unit perhaps you can try to swap out the gimbal and see if the problem is the firmware or the hardware. I don't know, this may seem like overkill, but you seem to have tried already to revert the firmware and all the other things you could've done.


    Sent from my iPhone using PhantomPilots