Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 3 Advanced Video Lag SOLVED!

Discussion in 'General Discussion' started by soupbone10, Aug 19, 2016.

  1. soupbone10

    Joined:
    Mar 31, 2016
    Messages:
    34
    Likes Received:
    2
    Location:
    Stockport. UK
    I have a 4 month old Phantom 3 Advanced and I've noticed that the lag on my Nexus 7 2013 (unlocked & rooted) has become worse,about 4-6 seconds.
    After much interweb searching, I came across a piece by Godfear17 and his approach to the video lag which involved stripping down the gimbal and adding/replacing the thermal pads.
    The thermal pads were ordered off Fleabay for the price of a beer and I set about doing the job.

    It is not that difficult if you take your time. I have tested the video link to the tablet and can confirm there is now NO lag. This fix DOES work.

    I have attached a few photos which may help anyone attempting to have ago.

    20160819_130812.jpg
    20160819_125134.jpg
    20160819_130254.jpg
    20160819_140017.jpg
     
    #1 soupbone10, Aug 19, 2016
    Last edited: Aug 19, 2016
  2. Easy-V

    Joined:
    Aug 4, 2016
    Messages:
    33
    Likes Received:
    5
    So, the implication is that the xmitter is overheating in the gimbal?
     
  3. soupbone10

    Joined:
    Mar 31, 2016
    Messages:
    34
    Likes Received:
    2
    Location:
    Stockport. UK
    I believe the Arm2 chip is overheating due to there being no thermal pad between it and the heatsink.
     
  4. BigAl07

    BigAl07 Moderator
    Staff Member

    Joined:
    Jan 5, 2015
    Messages:
    2,362
    Likes Received:
    1,267
    Location:
    Western North Carolina
    So the assumption is there is no thermal bridge to take the heat from the chip to the heat-sink (which would then transfer it into the atmosphere)? That would definitely cause over heating on the chip for sure. Maybe the person responsible for applying the thermal pads had to take a PEE break and the production line didn't want to wait :)

    Can you un-do it for us and make a BEFORE & AFTER video? Just kidding LOL

    But to anyone else who is debating this solution make us a before & after video showing the lag and lack of lag.
     
    soupbone10 likes this.
  5. soupbone10

    Joined:
    Mar 31, 2016
    Messages:
    34
    Likes Received:
    2
    Location:
    Stockport. UK
    This is the forum member who has the most info, I believe he may be making a how-to video at some point.
    Phantom 3 Advanced Video Lag FIXED! – UAVDoc
     
    BigAl07 likes this.
  6. Soulmetzger

    Joined:
    Jul 12, 2016
    Messages:
    42
    Likes Received:
    15
    I always thought my video lag was due to interference but I might have to do some of my own testing after seeing this post. I myself am using a Nexus 7 Gen2 with my P3A.
     
  7. soupbone10

    Joined:
    Mar 31, 2016
    Messages:
    34
    Likes Received:
    2
    Location:
    Stockport. UK
    Apart from the lag I also had video break up with flashing etc. Do the testing, hope this fix helps.
     
  8. matti

    Joined:
    Mar 15, 2016
    Messages:
    401
    Likes Received:
    62
    I had video lag in DJI GO and Litchi when using an underpowered tablet. Switching to a new tablet fixed that. So there might several causes for it.
     
  9. Soulmetzger

    Joined:
    Jul 12, 2016
    Messages:
    42
    Likes Received:
    15
    Is a Nexus 7 2013 still fast enough?
     
  10. soupbone10

    Joined:
    Mar 31, 2016
    Messages:
    34
    Likes Received:
    2
    Location:
    Stockport. UK
    A nexus 7 2013 is up to the job, best if you remove unwanted apps.
     
  11. Moises Edid

    Joined:
    Sep 27, 2015
    Messages:
    5
    Likes Received:
    0
    Dear soupbone10, I currently have the same problem you mentioned you fixed a few months ago(vídeo lag of 1-2 seconds). I have the current DJI go app and firmware 1.8 (had 1.9 but downgraded to see if it fixed the problem which it didn't)
    I am wondering what do you make of this problem now? Why did it start happening? (My P3A just turned one year old). Problem started around May/June.
    I am in Mexico and before I get into opening the gimbal or sending it to get fixed somewhere here you might have another suggestion?
    Thanks for your valuable input in advance!
     
  12. Moises Edid

    Joined:
    Sep 27, 2015
    Messages:
    5
    Likes Received:
    0

    Dear soupbone10, I currently have the same problem you mentioned you fixed a few months ago(vídeo lag of 1-2 seconds). I have the current DJI go app and firmware 1.8 (had 1.9 but downgraded to see if it fixed the problem which it didn't)
    I am wondering what do you make of this problem now? Why did it start happening? (My P3A just turned one year old). Problem started around May/June.
    I am in Mexico and before I get into opening the gimbal or sending it to get fixed somewhere here you might have another suggestion?
    Thanks for your valuable input in advance!
     
  13. Soulmetzger

    Joined:
    Jul 12, 2016
    Messages:
    42
    Likes Received:
    15
    I put my Nexus 7 in airplane mode and it seems to work perfectly with no lag. I just have location on and nothing else.