Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 3 Advance Take off fail

Discussion in 'Pro/Adv Discussion' started by Luacs_Awab, Dec 13, 2015.

  1. Luacs_Awab

    Joined:
    Dec 13, 2015
    Messages:
    1
    Likes Received:
    0
    Hey guys I'm German and i need your help! I've sent my DJI to "DJI GmbH" to repair the remote. as it came back to me a day ago i wanted to fly again. the problem is it doesnt take off and makes this wierd sounds (Video) The remote an the DJI drone are conected and they got the latest update. So whats the problem? pleas help me beause no one could help me even in the german forums Thank you very much (and sorry for my english)

     
  2. AngelPilot4u

    Joined:
    Jul 16, 2015
    Messages:
    38
    Likes Received:
    10
    What version of firmware is the aircraft on ?
    I would start with a cold IMU .. If that doesn't work, I would reinstal the firmware,
    consider 1.4 I this its better than 1.5.
     
  3. beeline

    Joined:
    Jun 17, 2014
    Messages:
    309
    Likes Received:
    53
    Location:
    North Alabama
    How is 1.4 better? Honest question because I'm still on that too.
     
  4. AngelPilot4u

    Joined:
    Jul 16, 2015
    Messages:
    38
    Likes Received:
    10
    Ive been on 1.4 for 200 flights with no problems, I know so many poeple that upgraded to 1.5 that reported bugs and malfunctions.. there is nothing really new in 1.5 as far as bug fixes, that's 1.5 for the aircraft not the RC. If its working don't fix it chances are you'll end up breaking it. DJI build 1.5 to prevent users from downgrading below 1.4, my opinion is that they don't want users to download previous firmware that would remove goefencing flight restrictions.
    there is a website that has previous firmware versions and older DJI app versions should you have a need for that >> Download | Jogjasky
     
    #4 AngelPilot4u, Dec 17, 2015
    Last edited: Dec 17, 2015
  5. beeline

    Joined:
    Jun 17, 2014
    Messages:
    309
    Likes Received:
    53
    Location:
    North Alabama
    Sorry for my late response. I just saw this.
    Does this mean I can downgrade to any version from 1.4? Would the Go app have to be downgraded as well?

    Thank you for your insight.
     
  6. Oso

    Oso

    Joined:
    May 19, 2015
    Messages:
    2,539
    Likes Received:
    1,486
    Location:
    Sacramento CA
    You can download to one version below the highest that you previously had installed with a floor of 1.3x. If you've had 1.5x, you can only go back to 1.4x. If the highest you have had is 1.4x, you can only go to 1.3x. If you have 1.3x, you can't downgrade. Also, you can't go from 1.5x to 1.4x and then go to 1.3x. Just one below the highest that you previously had installed.

    Most older FW versions are available on the DJI site. You just need to type in the URL and you can get them from DJI directly.
    Here are the lnks:
    Dji updated my p3p??? | DJI Phantom Forum
     
  7. GunnyPapa

    Joined:
    Nov 28, 2015
    Messages:
    201
    Likes Received:
    39
    Has anybody helped this guy from Germany or are you starting another thread?
    Guy in Germany Luacs it sounds like one motor is contaminated with a foreign small object. Inspect all motors inside arms. Let me know. Also your English is fine. PM me if you want.
     
  8. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,759
    Likes Received:
    3,469
    The gaping hole in that theory is that DJI themselves have announced that they intend giving owners the option of overiding the current geofencing.