Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 won't engage motors when using spare battery

Discussion in 'Phantom 2 Help' started by FearInLothian, Feb 13, 2015.

  1. FearInLothian

    Joined:
    Feb 13, 2015
    Messages:
    4
    Likes Received:
    0
    I recently took my phantom 2 into the shop to get the gimbal fixed, it was fixed and recalibrated and the guys in the shop kindly updated the firmware on the phantom. Since then I've not been able to use any spare batteries, I get one flight and then insert the spare, I go through usual start up lights but when they flash green and I pull the sticks inwards and down, the lights start to flash red and the motors wont engage. It's def not the battery as i have swapped them over and it only happens after either battery has been drained and replaced with another full one. Usually I can put in either battery the next day and it starts up fine but the problem recurs after a single flight. Im sure it must be the firmware but wanted to know if anyone else had experienced the same issue? If so what was the best solution? Thanks
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,034
    Likes Received:
    5,603
    Location:
    US
    Tell us about the process you follow to swap the batteries after the first successful flight.
     
  3. FearInLothian

    Joined:
    Feb 13, 2015
    Messages:
    4
    Likes Received:
    0
    Switch off dead battery, slide out, put new one in and switch on, I usually remember to switch off the rc but not always and it doesnt seem to make a difference
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,034
    Likes Received:
    5,603
    Location:
    US
    That process sounds okay.

    All of the known flashing red light patterns are battery related. Did you try cleaning your battery contacts?