Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 Vison + Spinning

Discussion in 'Phantom 2 Vision + Discussion' started by pannus, Feb 8, 2015.

  1. pannus

    Joined:
    Feb 8, 2015
    Messages:
    3
    Likes Received:
    0
    Crashed my Phantom one week ago. Solder on main circuit board came off. Replaced circuit board, ESC 2.1 x 4 and motors. Everything is wired properly. Been over it 200 times. Recalibrated advanced IMU and controller. Phantom fires up as it should. I calibrate compass. Idles perfectly.

    When I go to lift off, the Phantom spins like a top and crashes. All motors verified spinning in correct directions, ESC's wired properly. If anyone here has ANY help I would so appreciate it. I've wasted the entire weekend on this and I am beating my quad to death.

    Drury
     
  2. pb7424

    Joined:
    Aug 7, 2014
    Messages:
    149
    Likes Received:
    4
    Location:
    Two Rivers, Wisconsin
    Are you sure the new motors were installed on the correct arms? Looking at my quad with the camera facing me, the black dot motor is on the right at the front of the quad and on the left at the rear of the quad.
     
  3. pannus

    Joined:
    Feb 8, 2015
    Messages:
    3
    Likes Received:
    0
    wow. mine are back-asswards. If this works, you get a beer.
     
  4. pb7424

    Joined:
    Aug 7, 2014
    Messages:
    149
    Likes Received:
    4
    Location:
    Two Rivers, Wisconsin
    Hope that's the fix. :)
     
  5. SteveMann

    Joined:
    Aug 27, 2014
    Messages:
    1,977
    Likes Received:
    653
    Location:
    Westford, MA
    Now you know the maximum yaw rate.
     
  6. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,237
    Likes Received:
    916
    Location:
    Indy, USA
    I was just getting ready to mention because I did something similar to this a few years ago. Good luck and be ready to buy that beer.
     
  7. pannus

    Joined:
    Feb 8, 2015
    Messages:
    3
    Likes Received:
    0
    That was the solution to the problem. Thank you. Don't know how I installed them on the wrong arms. DOH!
     
  8. pb7424

    Joined:
    Aug 7, 2014
    Messages:
    149
    Likes Received:
    4
    Location:
    Two Rivers, Wisconsin
    Glad you got it worked out. Happy flying!
     
  9. Phantom_Menace66

    Joined:
    May 8, 2014
    Messages:
    469
    Likes Received:
    2
    Location:
    Perth, Western Australia
    What goes red, white, red, white at 100rpm? A Phantom with the motors *** backwards! Lmao :lol:
     
  10. Wibble

    Joined:
    Feb 7, 2015
    Messages:
    1,313
    Likes Received:
    478
    Location:
    Brecon Beacons Wales UK
    AWESOME thanks for that made me smile!!!!!!!!!!!