Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 Vision+ Will Not Turn On

Discussion in 'Phantom 2 Vision Discussion' started by iamjevans, Jun 18, 2014.

  1. iamjevans

    Joined:
    Jun 18, 2014
    Messages:
    4
    Likes Received:
    0
    I am flying the DJI Phantom Vision 2+. I purchased two batteries and I have fully charged both of them. I had two brief, but successful flights. I am not trying to fly for a 3rd time. I press the on button once and hold for 2 seconds. I then press again and hold for 2+ seconds and the unit does not turn on.

    Also, not sure if this is weird or not but, when I press the power button all 4 lights on the battery turn on at once, they don't turn on one by one until they are all lit.. they just all turn on at once.

    When I plug the unit into my computer and open the Phantom software it tells me to connect my Phantom because it can't tell that its already plugged in due to the unit being off.

    I have tried this with both batteries and nothing is working..

    Any ideas?
     
  2. RCRookie

    Joined:
    Mar 9, 2014
    Messages:
    703
    Likes Received:
    11
    Location:
    East Texas
    Ive done this myself...I think your holding the first press too long. Try a quick first press...then immediately repress ( hold for2-3 seconds)
     
  3. iamjevans

    Joined:
    Jun 18, 2014
    Messages:
    4
    Likes Received:
    0
    Wow.. That's embarrassing. Next time make it sound a little more complicated than that :)

    What you suggested totally worked.

    Thank you again.
     
  4. RCRookie

    Joined:
    Mar 9, 2014
    Messages:
    703
    Likes Received:
    11
    Location:
    East Texas
    Its an easy mistake to make...I did it with two batteries..luckily I had a friend who I showed how to turn the battery on only a week before. And he showed me how....AGAIN. lol
     
  5. J Dot

    Joined:
    Apr 10, 2014
    Messages:
    1,756
    Likes Received:
    895
    Location:
    Sarasota, FL. USA!
    You might be pressing too long on the first press?

    Should be :

    1 quick press ( fraction of a second ) you see 4 LEDs on if fully charged
    Then
    1 long press ( 2-3 seconds ) you'll see LEDs run a sequence ( 1,2,3,4 ) if fully charged!

    Same sequence shutting battery off.

    Also will the batteries turn on while ( not installed in phantom ) ?

    Keep us informed!

    Take care, fly safe!
     
  6. BigTulsa

    Joined:
    May 29, 2014
    Messages:
    207
    Likes Received:
    1
    Location:
    Tulsa, OK
    Don't feel bad; I did that too the first night. Did it in reverse also (trying to turn it off).
     
  7. iamjevans

    Joined:
    Jun 18, 2014
    Messages:
    4
    Likes Received:
    0
    Thank you for the help everyone.
     
  8. plimpert

    Joined:
    Jul 2, 2014
    Messages:
    8
    Likes Received:
    1
    Everything the previous person stated as his problem is what I am now encountering. I have tried the fixes suggested in this post but to no avail. I push the button once for a fraction of a second and all 4 bars light up and hold for 2-3 seconds, and I do mean I push for only a fraction of a second. Then, I press and hold for 2-3 seconds and instead of the normal 1-2-3-4 sequence and turn on, all I get is 4 bars lit while I hold the button and then they go off and the phantom does not power up.
     
  9. RCRookie

    Joined:
    Mar 9, 2014
    Messages:
    703
    Likes Received:
    11
    Location:
    East Texas
    You're pressing to long on the first press.

    Press ONCE quickly release.
    Immediately RE-PRESS and hold for 3-4 seconds.
     
  10. plimpert

    Joined:
    Jul 2, 2014
    Messages:
    8
    Likes Received:
    1
    Honestly, I have been doing this correctly for 2 weeks and I am not holding it any longer now than I have for the past 2 weeks flying everyday. Since reading posts here including your feedback, I have tried various retry's attempting only a quick punch and then hold and release and nothing seems to be working.
     
  11. plimpert

    Joined:
    Jul 2, 2014
    Messages:
    8
    Likes Received:
    1
    My apologies to the forum... I swear I was doing the same power up push button touch sequence as always, but apparently I was not. Both batteries appear to be working now... Ugh!
     
  12. plimpert

    Joined:
    Jul 2, 2014
    Messages:
    8
    Likes Received:
    1
    My apologies to the forum... I swear I was doing the same power up push button touch sequence as always, but apparently I was not. Both batteries appear to be working now... Ugh!