Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 Vision Blinks Red When Trying To Start Motors

Discussion in 'Phantom 2 Vision Discussion' started by iam3toed, Apr 1, 2014.

  1. iam3toed

    Joined:
    Mar 25, 2014
    Messages:
    1
    Likes Received:
    0
    Check out the vid here:
    http://youtu.be/_3pwwg3SrrA
    I'm stuck with red flashing lights when I pull the sticks in and down on the controler. This happened after the 2.0 update. Also, I can't get out of NoGPS mode. When I toggle the S1 switch 20+ times nothing happens. Anyone else have this issue?
     
  2. Lastor

    Joined:
    Mar 28, 2014
    Messages:
    24
    Likes Received:
    0
    Did you try to reflash it again?
    During the software upgrade process did you get any fault massage or something went wrong?
     
  3. RCRookie

    Joined:
    Mar 9, 2014
    Messages:
    703
    Likes Received:
    11
    Location:
    East Texas
    3 RED flashes is sensor bias too big. Run your IMU Calibration and reboot. Worth a try.
    Do all your updates now reflect the newest version on the info screen in the Assistant ?
     
  4. BlackTracer

    Joined:
    Mar 29, 2014
    Messages:
    980
    Likes Received:
    22
    Location:
    Winter Park, FL USA
    I calibrated everything calibratable after I did the updates. Th IMU (deep cal), the sticks, the compass. I think the assistant told me to cal the IMU after I updated.
     
  5. F6Rider

    Joined:
    Feb 5, 2014
    Messages:
    1,126
    Likes Received:
    346
    Location:
    Foothills Of The Sierra's, California
    I had to power cycle the phantom 3 times after the update to get rid of the firmware mis-match message. I calibrated the sticks and X1 but the IMU said it did not need calibration. I tested the motors without props and it started fine. When I first up-Packed the new bird the sticks were so far out of calibration they would not start the motors, and I had red lights, after calibration all was good and has been so for 40 flights or so (knock on wood)
     
  6. rfernandez

    Joined:
    Jan 20, 2014
    Messages:
    373
    Likes Received:
    0
    go to the card that ams with the phantom and read the color coded lights !!
     
  7. SilentAV8R

    Joined:
    Apr 2, 2014
    Messages:
    943
    Likes Received:
    18
    Location:
    Orange County, CA - USA
    A couple of things I noticed. The yellow blinking lights mean you are in NON-GPS mode. Calibrate the compass outside and away from any metallic objects and then let the Phantom find all the satellites. Once it does and you are in GPS mode the rear lights will blink green.

    Also, not sure where you are located, but your transmitter is in CE mode. That's what the single beep is telling you when you turn the transmitter on. If you are in the US you want to be in FCC mode, which will be 2 beeps when powering up the TX.
     
  8. wcasado

    Joined:
    Aug 17, 2014
    Messages:
    1
    Likes Received:
    0
    Hi iam3toed, I would like to know if you fix your problem.
    I have the same problem on my Phantom Vision 2+.
    Any help will be deeply appreciated, I'm grounded now!