Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 motors not timing out.

Discussion in 'Phantom 2 Help' started by klik, Jun 29, 2014.

  1. klik

    Joined:
    Jun 28, 2014
    Messages:
    2
    Likes Received:
    0
    First issue, battery not connecting with pins that power the receiver. How do you keep these clean and a good connection? After loosing connection the quad it went into failsafe mode and flew down and clipped the house flipping upside down on the ground with the motors running at nearly full throttle. The only way to stop it was pull the battery out. Connected quad to the DJI assistant and did all the checks and reset everything. Now the motors do not time out. The motors will run for ever sitting on the ground. They don't time out and turn off.
     
  2. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    Not quite sure what you mean by "timing out"...do you hold the left stick all the way down to shut them off, or use the CSC combo?
     
  3. klik

    Joined:
    Jun 28, 2014
    Messages:
    2
    Likes Received:
    0
    Hello, I was thinking once you start the motors if you don't advance the throttle the motors would automatically turn off after about 5 seconds. Is that not true?
     
  4. N017RW

    Joined:
    May 2, 2014
    Messages:
    6,236
    Likes Received:
    1,612
    Location:
    Palm Beach Co.- FL
    That is a feature found around page 10 if the NAZA-M V2 manual.

    There is a selection box in the P2 assistant s/w for immediate or intelligent shut-down.

    I'm not sure if it can actually be enabled or if the other P2 variants (V, V+) have this option in their assistant s/w as well.

    I have never tried to enable immediate shut-down for what I think are obvious reasons.