Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 jiggles in flight after installing landing gear

Discussion in 'Phantom 2 Help' started by gclindsey, Aug 23, 2014.

  1. gclindsey

    Joined:
    Aug 16, 2014
    Messages:
    7
    Likes Received:
    0
    After installing an iosd mini and it mounting internally, and then installing simensays v3 carbon fiber landing gear, the phantom jiggles in flight.

    https://www.youtube.com/watch?v=OWoqXnIaj2I

    I'm not sure why its doing this, but my guess is that there's a bad motor, ESC, or the placement of the wiring inside the craft is messing it up somehow. When I installed the iosd mini, I cut the ziptie binding the wiring in the rear right arm (I believe) and didn't replace it. Could that be the issue?

    I need to do a proper IMU calibration, I tried earlier but its said the MC was too warm. I recalibrated the compass and the values look alright (the Z value is around 300 everything else is as it should be but I think this is ok.) Also I did not update the iosd mini after installing, it appeared to work fine and I didn't have access to a PC.

    It would be great to take this thing out filming finally!
     
  2. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    Re: Phantom 2 jiggles in flight after installing landing gea

    I would start with a full IMU calibration (you can ignore the "MC too hot" message and click past it, it's an old bug in the software).

    What is the "Mod" value all the way to the right where you see the compass readings? It looks like your compass is re-mounted correctly but it's hard to tell for sure.
     
  3. gclindsey

    Joined:
    Aug 16, 2014
    Messages:
    7
    Likes Received:
    0
    Re: Phantom 2 jiggles in flight after installing landing gea

    The compass Mod value hovers around 1200, x is around 140, Y is 80, and Z is 260. I'm doing an Advanced IMU Calibration but honestly I can't tell if anythings happening. The status bar is halfway filled though, but the "Advanced Cali" button isn't greyed out I can still click it. Its been going for 10+ minutes.

    Also, should the transmitter be on? Its off right now and the lights are flashing yellow.
     
  4. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    Re: Phantom 2 jiggles in flight after installing landing gea

    The compass value looks a bit low, you might need to follow this procedure to fully recalibrate it (when the basic pre-flight calibration doesn't help enough): https://www.youtube.com/watch?v=kCT1rRE_UIg
     
  5. tferrari

    Joined:
    Aug 4, 2014
    Messages:
    145
    Likes Received:
    1
    Re: Phantom 2 jiggles in flight after installing landing gea

    I think your gains are too high. I know you didn't change them, but this is exactly what high gains will produce as a symptom.

    In the DJI assistant software, go into the gains section and turn the BASIC GAINS down by 10% at a time until your wobble disappears.

    Follow the instruction here under 'Basic Parameters' to optimize further http://wiki.dji.com/en/index.php/Naza-M_Autopilot_Setting
     
  6. gclindsey

    Joined:
    Aug 16, 2014
    Messages:
    7
    Likes Received:
    0
    Re: Phantom 2 jiggles in flight after installing landing gea

    I resolved the issue by taking it in and having someone fix it. The gains were indeed to high and I adjusted them myself. However a separate issue arose while I was doing that so I decided not to spend more time on it and let a pro handle it. Now it flies great.

    The other issue happened when I hooked up the TX to the RC assistant software to calibrate and the X1 channel got screwed up. This had happened before and I needed a new transmitter so I decided I would just take it in and I'm glad I did.