Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 FPV Telemetry data no video

Discussion in 'Phantom 2 Discussion' started by dano7602, May 31, 2014.

  1. dano7602

    Joined:
    Apr 24, 2014
    Messages:
    64
    Likes Received:
    0
    Just got my whole FPV set up on my phantom 2 with IOSD Mini with one problem no video picture on my black pearl. I receive the telemetry data from the iosd mini however for some reason the video from my go pro does not seem to be coming through. I am using a Tarot gimbal so I had to solder the tarot go pro cable to my plug and play set up (this might be where the problem lies). I figured the transmitter and black pearl must be set up right if I am able to see telemetry just scratching my head on what the problem can be. Also how do I charge my blackpearl internal battery my monitor did not come with the charger and the charger that flysight offers to charg the monitor seems to be sold out everywhere. Can I use a laptop charger since I do not have the black pearl charger?
     
  2. sergekouper

    Joined:
    Apr 20, 2014
    Messages:
    752
    Likes Received:
    128
    Location:
    London UK
    Is your GoPro on? and in what mode? sounds stupid but when I got my FPV on for the first time, it was the same, the IOSD was showing but not the cam. I was seeing the red light on and thinking it was on. was not, just charging! :D So I started it and O Miracle! I hope it's just that for you too.
     
  3. Deadmeat

    Joined:
    Dec 28, 2013
    Messages:
    42
    Likes Received:
    1
    Location:
    Co.Antrim, Northern Ireland.
    If it`s sending the iosd info the tx is working so it is either a crossed connection or something simple......you would hope ;)
     
  4. Ryanhenry

    Joined:
    Jun 2, 2014
    Messages:
    7
    Likes Received:
    0
    Dano, did you get it sorted out? I have the same issue. Getting the info from iosd mini on the monitor but no video from gopro. Using fpv plug n play cable so wiring should be fine. Camera & monitor both on pal.

    If anyone can help id appreciate it.

    Thanks
    Ryan
     
  5. ussvertigo

    Joined:
    Jan 28, 2014
    Messages:
    333
    Likes Received:
    68
    Location:
    South Georgia
    Same problem, don't use pal but I suspect my 2d gimbal is not passing video thru, don't know how to test.
     
  6. ussvertigo

    Joined:
    Jan 28, 2014
    Messages:
    333
    Likes Received:
    68
    Location:
    South Georgia
    Actually I just did a simple test that confirmed my fear the video signal is getting lost between the camera and the female ribbon cable plug in at the other end of the zenmuse. Hooked some jumpers to the RCA video out plug of an old video camera and to the video input of the gimbal ribbon cable and then got my picture with overlay. For now I will get a 90degree usb video out cable for $5 and wire it into the iOSD mini.